Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Finally upgraded my MacBook Pro (Unibody late 2008) from leopard to snow leopard, with a view to go to Lion when it finishes downloading. I've now noticed that hitting the single button on my Etymotic HF-2's no longer play/pauses the media in the active player but launches iTunes if it's not running, and play/pauses iTunes content if iTunes is running. Historically on Leopard, pressing this button would cause the active player to play/pause, be it Spotify, VLC or any other media player (Though spotify and VLC are my most used players)

Anyone know how to return to this behavior?

share|improve this question

3 Answers 3

You have to combine both answers posted here.

Configure ControllerMate as described by Luke for your program of choice and apply the Play Button iTunes Patch mentioned by Stephen.

Then you can control your app of choice by using a headphone remote control without starting iTunes.

share|improve this answer

I believe this will fix your problem MMFix. Let me know if it works!

share|improve this answer
    
Works for the media keys (yay) but not for the headphone button :( –  Michael Jefferys May 29 '12 at 15:36
    
Oh I lied, it does block the start up of iTunes on the headphone button click, but doesn't pass the play/pause action to spotify/VLC which is what I really want :( –  Michael Jefferys May 29 '12 at 15:43
    
Try this and see if it works any better iTunesPatch. –  Stephen May 29 '12 at 16:01
    
Nope, same problem :( –  Michael Jefferys May 29 '12 at 22:09

You can do this with ControllerMate:

enter image description here

And a little little AppleScript (each line for each function):

tell application "Spotify" to playpause
tell application "Spotify" to next track
tell application "Spotify" to previous track

If you open QuickTime Player it will silently ignore the play/pause button and prevent iTunes from being opened, if you don't iTunes will still try to play something. Another solution to prevent iTunes from starting is to disable the 'Remote Control Daemon', how to do this is explained in detail on superuser.

share|improve this answer
    
Took a minute to figure out the setup, but ControllerMate works perfect, Thanks! Running Mac OSX 10.8.3 There is one lingering issue though. The initial play/pause click on the headphone will still open iTunes. Thereafter, controls continue to work with spotify. Is there a way to disable this with ControllerMate? –  jpann Mar 29 '13 at 5:01
    
Unfortunately not. You have to keep QuickTime open. –  Luke Mar 29 '13 at 15:44
    

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.