Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I just picked up 16GB of RAM for my MacBook Pro, running the newest OS X. According to the NewEgg reviews, it should work in it. However, once I boot up, it shows the Apple logo and, after a few seconds, the spinner just freezes.

If I boot into my Windows 7 partition, it lists 16GB as installed, and 15.7GB available. Why, then, is OS X not recognizing it?

I've tried each of the sticks themselves (1x8GB), and OS X still freezes. The RAM came as 2x8GB and are PC3-10600 @ 1333 MHz.

I've tried holding D as the computer boots, but it just gray screens for a while, then jumps to the Apple logo.

It seems to me that 16GB may not work, but why then does the same hardware, just Windows 7 successfully run?

share|improve this question
    
@geoffc: It's a 2.4 GHz Core 2 Duo. It's the provided one at my new job, and eclipse is tearing up the 4GB it has in it atm. My personal one has 2x4GB, but I apparently didn't do enough research before assuming that all OSX supported 16gb. I still don't understand why Win7 reports it as there though. –  Josh May 25 '12 at 20:38

2 Answers 2

up vote 4 down vote accepted

Your Mac needs to meet specific criteria for this to work. In the case of the 2010 Macs, here’s what you must have:

  • a Mac mini (Mid-2010), a MacBook (Mid-2010) or a 13” MacBook Pro (Mid-2010)
  • Mac OS X 10.7.5 or later
  • the latest EFI firmware update for your system
  • the proper specification memory modules

See Certain 2010 MacBook, MacBook Pro, and Mac mini models join the ’16GB’ MaxRAM club for details.

You will need (2x8GB) 16GB DDR3-1066MHz SODIMM. Anything faster like a DDR3-1333MHz or DDR3-1600MHHz SODIMM will fail to boot the machine.

share|improve this answer
    
Or, if you're a cheapskate like me, you can mess with the EEPROM on a 1333MHz stick. It worked for my Mid-2010 13 inch MacBookPro 7,1, but don't try it if you are nervous about that kind of tinkering. –  Sinan Ünür Mar 18 '13 at 23:26

According to Mactracker, the MacBookPro7,1 is a 13" MacBook Pro and it only supports 8 GB of RAM. (For machines that support 16 GB, it mentions that Apple says it supports 8GB but it'll actually work with 16.)

So OS X probably just doesn't know how to talk to 8 GB sticks on that chipset. My recommendation would be to return the RAM and get 2x4 GB.

share|improve this answer
    
I figured as much, after more heavily researching it. Any thoughts as to why Win7 can see it? Is it perhaps just a Firmware issues? –  Josh May 25 '12 at 21:15
    
Windows 7 has better support than OS X for that chipset? Apple usually doesn't bother supporting what they decide they don't want to, and that appears to be something they decided they didn't want to support. –  CajunLuke May 25 '12 at 21:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.