Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a wireless network in my apartment. Because the apartment is large and walls are concrete, it was very hard to get wifi coverage throughout the whole place. Therefore I have one Airport Extreme, and then multiple Airport Expresses, and I have configured the airport expresses to join and extend the wireless network that is created on the main (airport extreme) unit.

The question: When I am far from the original (airport extreme) unit, my iPad has no problem getting a four-bars connection from the satellite airport express that is relaying the connection. BUT, my ipod touch (and my Kindle also) can NOT connect to it. They just want to connect to the main central unit.

believe me I have re-configured this thing a DOZEN times... using the crystal clear normal method to get the distributed network going across all the airports... always the same problem.

Has anyone found this to be the case -- that the iPod Touch, and a regular lowest-level kindle (bottom of the line unit as of 2012), will not connect to the WDS satellite, only the main unit?

[I will admit, i am only somewhat sure that the method I use, where I configure the units to "join and extend" the main network, is actually the same as WDS.]

share|improve this question
2  
It might be that the iPod Touch was first connected to the main AirPort Extreme and has that in its remembered network access point. If you reset Network settings on the iPod Touch, then turn off wifi on it, then move next to one of the satellite AirPort Expresses, then turn wifi on again, it will pick up the satellite instead of the main base station. The downside is that there is no way that I know of to reset a single remembered network, you've got to kill all your remembered networks to do this. It might not be a bad idea to do once in a while anyway. –  Richard May 21 '12 at 10:25
    
Your advice above is sharp. However, I did those exact steps, and when it came to sitting next to a satellite and turning on wi-fi again, it still failed to "see" the satellite router. only when I wandered closer to the hub router would it report seeing my wireless net... –  estephan500 May 22 '12 at 5:27
    
HOWEVER, your experiment demonstrated something interesting. When I went over to ANOTHER of my satellite routers, it DID report that it saw the network (with an appropriate, strong signal) -- but this satellite that "worked" is in fact my OLD airport express, which is only a 802.11g, and not the nice newer 802.11n ones that are in the more important zones. Seems that somehow my iTouch is wanting to talk to "g" routers when using WDS?? Can I configure the newer Express satellites to have a mode friendlier to "g"-hungry clients? Thanks for this help! [you should post as 'answers,' not comments!] –  estephan500 May 22 '12 at 5:33
    
OK, learned more and found a solution, which I've posted as "answer." By using this solution, I realize that in my case I am causing a lot of the traffic on my devices to go only through 802.11 b/g, which is sad to think that I am forgoing the benefits of N. but at least I'm getting connected on all my devices... –  estephan500 May 23 '12 at 4:19

1 Answer 1

up vote 0 down vote accepted

I've pretty much solved this problem. I do not FULLY understand why, but now I can have my iPod touch (and I am hoping my kindle) attach correctly to the satellite/repeater airport express. Here is what I did:

I did two configuration changes to my central hub airport extreme router (i.e., the one that my other routers were merely configured to "extend.") I realize now that these are both configurations that must be done at that central router, and the repeater routers then simply mimic or reflect accordingly.

-- First, I used the most recent Airport Utility (v6.0) and clicked on my main router (which, crucially, is an airport extreme that has dual band 802.11, both 2.4ghz and 5ghz.)

-- In the airport utility, I clicked on that Extreme router and then in its funky popup window, clicked Edit.

-- Clicked the tab called Wireless.

-- Clicked on Wireless Options button.

-- the first config change I made on that page was to change the Radio Mode setting to "802.11a/n - 802.11 b/g."
What nobody really tells you is that that hyphenated choice means that the 5GHz band will use the first of those two (namely, a and n, in other words the strong modern N standard will be used on this band ONLY) ... while the 2.4GHZ band will use only the second of those two, b/g, in other words, the devices that only can use that older weaker standard. So, it's kind of a segregation. I'm telling it "No, don't let the 2.4 ghz band try to handle traffic using N. That band will just take care of the old crappy clients."

-- the second config change that I made on that page was to check the check box to make a totally separate wireless network name for the 5GHZ band. Further segregating things. When I tried my solution without this additional step, my problem did not fix itself, though I don't fully see why.

As I said, a few questions remain in my head, but the darn thing works, so I'm happy. Among many other questions... are those airport expresses dual-band too? I didn't think they were but somehow they are repeating this dual-band strategy? Whatever. it works.

Wanted to say thanks to Richard, whose reply caused me to get off my butt and try more investigating into this.

share|improve this answer
    
I was the person that asked this question to begin with, and I was the person that gave this nice full answer to it. And now I just want to compliment myself for such a full answer, because it is now a long time later and I am having a new problem that this answer is now solving for me. Hooray, me! –  estephan500 Mar 9 '13 at 8:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.