Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My iPad won't rotate the screen anymore when I turn it. It just happend (like all problems of course) without any cause.

I've done everything I can think of.

  • Double tap on the Home button, swipe left and toggle the switch
  • Toggle the switch on the left side of the iPad with 'rotation lock' set to on
  • Reboot the iPad
  • Restore the iPad

I'm out of options... Anyone with more options? Or is it hardware to blame?

share|improve this question
4  
Stand on your head? But seriously, what version of iOS and which generation iPad are you using? –  Daniel Lawson May 20 '12 at 19:29
    
Lol :-) it's an iPad 2 with iOS 5.1.1 –  Michiel May 20 '12 at 19:35
1  
Which orientation is it stuck in? –  Daniel Lawson May 20 '12 at 19:39
1  
Did you restore from a backup, or was it a fresh restore? –  Nix May 21 '12 at 3:29
2  
The fact that it is still not working after a fresh restore, given all the other stuff you've tried, makes me think it is a hardware issue and there's something wrong with the accelerometer. I'd be inclined to take it to an Apple Store and let them have a look at it. –  Nix May 21 '12 at 12:44
show 2 more comments

2 Answers

up vote 7 down vote accepted

Since you've restored the iPad I would say that you've got some issue with the Hardware. If possible, Take it to an Apple Store for a Hardware test.

Using an app which requires the use of the Accelerometer may test it too.

EDITED: Its not the Gyroscope what tells the position of the device but the Accelerometer.

share|improve this answer
    
And app you can recommend? –  Michiel May 21 '12 at 13:26
    
Real Racing :-) –  patrix May 21 '12 at 13:31
    
Ok, thanks. Unfortunately, the iPad doesn't rotate at all anymore... Apple Store, here I come :) Thanks for your input! –  Michiel May 23 '12 at 8:46
    
Good luck with it. :) –  Thecafremo May 23 '12 at 9:18
add comment

I had same problem and after a lot of other things thought I'd try one more thing, I ran the battery completely and let it sit for a day. Recharged it and its now working fine.

MY theory is that perhaps the accelerometer can become magnetized and running the battery out and allowing it to sit, dissipated the energy. Just a though, but it worked.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.