Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have an iPad 2. 

Sometimes, after I stow it away into my bag, it will start playing music (using the music app) at the most inappropriate times: during class, in meetings... This behaviour seems to be connected to the screen saver feature, but I can't seem to find a way to turn it off!

Is there a way to turn this off, or to at least make it respect the volume setting? The music is audible even with the iPad muted otherwise.

Or am I just too dumb to find the right setting? I'm not excluding that possibility.

Edit: I have a passcode set.

share|improve this question
    
Do you have any kind of cover on your iPad? –  patrix May 19 '12 at 17:18
    
@patrix yeah, a leather one. (It has no interaction features though as the Smart Cover does.) –  Pekka 웃 May 19 '12 at 17:21
    
The only way to start the iPod app while the screen is locked is by double-tapping the home button and press play on the screen. This shouldn't happen with a cover though... What do you actually mean with "Screen Saver"? –  patrix May 19 '12 at 17:50
    
@patrix I think the correct term is "lock screen". It seems to me as if the lock screen offers the option of showing photographs, or playing music. That option seems to be activating itself, and I can't see a way to turn it off –  Pekka 웃 May 19 '12 at 18:31
    
I have a parallel problem, with apps playing music and sounds despite the mute switch being on. The iPad seems quite unreliable with respect to volume settings and muting. I'm looking forward to a good answer here! –  Ash May 20 '12 at 15:08
show 1 more comment

3 Answers

up vote 2 down vote accepted

Arrrgh.

I found the reason, my own stupidity. :) I use a Bluetooth keyboard whose keys are extremely sensitive to pressure when it's stowed in the backpack. It usually goes to sleep when not used, but wakes up when you press a key. The "play" key on that keyboard was what made the iPad blare away.

share|improve this answer
    
Thanks for coming back with the answer! –  patrix Aug 11 '12 at 10:33
1  
I just blew through 3 GB of data plan due to this. Keyboard was off, iPad was closed and locked with a passcode and smart cover. For whatever reason the keyboard got jostled in a way to turn the keyboard on, press play and similarly bad luck that the iPad didn't join the Wi-Fi and stayed on LTE all night playing music. –  bmike Mar 30 '13 at 17:57
add comment

A friend of mine recently had the same complaint. I couldn't find a solution online, but came up with this workaround:

Go to your Settings, General, Restrictions. Enable restrictions, set a passcode and disable iTunes.

It's a bit of a nuisance if you regularly use your iPad to listen to music, but most people with iPads have an iPhone or iPod for that.

Good luck!

share|improve this answer
1  
If you set a passcode, that should be fine, you shouldn't need to disable iTunes. –  Graeme Hutchison May 20 '12 at 6:07
    
Thanks, but the weird thing is I have a passcode set. (I'll add that to my question.) that makes me think it must be a built-in feature of the lock screen. Weird –  Pekka 웃 May 20 '12 at 9:41
    
@Porlock is talking about disabling iTunes, not a passcode for the lock screen. And yes, music playback is a lock screen feature, I just can't image how you could trigger this through a cover. –  patrix May 20 '12 at 9:47
1  
Do you have a Bluetooth keyboard? Sometimes the keyboard can be bumped in a bag and then activates the lockscreen even with a decent cover on your iPad. Either way, disabling iTunes removes it from your lock screen. –  Porlock May 21 '12 at 21:37
    
@Porlock You nailed it in my case - even with the smart cover, no home screen music controls, if the play button on the KB kets pressed, iTunes will play. I didn't mind this so much when all the music was on the iPad, but now with streaming - I ended up paying a lot for this little error. –  bmike Mar 30 '13 at 17:59
add comment

Got a few suggestions tough I'm not an iPad owner but it works for an iPhone.

1) how about turing the iPad completely off? ( by holding the power button, en slide to power off )

2) play some music and turn the volume down with the volume buttons this volume setting will be respected.

3) plug in head phones sound will be played trough the headphones so it won't be hearable.

But I find it really odd that it starts playing music in the first place, maybe your leather case does interact with the screen. After all leather is an animal skin.

share|improve this answer
    
But I find it really odd that it starts playing music in the first place - I don't find it odd - my ipad doesn't have much music on it, but it does still decide to make the odd sound despite the volume being muted and the screen being locked. Which I do find to be incredibly annoying, in particular at 3am when I left the ipad in my bedroom. –  RobM Jun 19 '12 at 12:50
1  
hmmm sounds like there is something wrong with your iPad. maybe try to make a backup and restore trough iTunes and if that doesn't help visit a apple store. –  FLY Jun 19 '12 at 13:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.