Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a problem with a seemingly unremovable directory/bundle. I moved Spotify.app from /Applications to the Trash and later tried to empty the Trash.

The empty trash progress bar shows up but then nothing happens anymore. No error message, no progress.

Then i tried to remove the directory with the following commands

rm -rfv ~/.Trash/*
sudo rm -rfv /home/<user_name>/.Trash/*

Both never return, can not be aborted with ^c and provide no output at all. I considered some filesystem corruption, rebooted in recovery mode and ran the disc repair. It found an error and fixed it, but the problem did not go away and i still have the same behavior.

Another potentially related problem is wrong meta information in the Finder. Since some weeks ago i repeatedly find files where the Finder shows no filesize, type, creation date, modification date.

Any ideas how to remove the directory or what might be the problem?

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

I was able to remove the directory in single user mode.

Before that i tried to remove the contents of the directory one by one and found that Spotify contained two Growl libraries one of which could not be removed. The library did not even show up with ls -l in single user mode.

share|improve this answer
    
Good find. Don't forget to accept your own answer. –  user479 May 22 '12 at 17:22
add comment

I use sudo rm -Rf (big 'R') when things are stubborn. It's a holdover from my Slackware days but I actually have no idea whether there's a difference on OS X.

However, sometimes restarting Finder using killall Finder can release locks on the Trash, which coincidentally can have the same effect.

share|improve this answer
add comment

Maybe some of the files are protected. In that case you won't be able to delete them the normal way. Apple provides a very handy manual for this. Just look for the section "Advanced tip about deleting locked files". I've used this procedure many times!

share|improve this answer
    
Good idea, but i think sudo rm -rfv /home/<user_name>/.Trash/* should have catched that case. I tried it never the less and found that chflags -R nouchg /Users/<user_name>/.Trash/Spotify.appdoes not return as well. And as with rm there are no error messages. –  jmaschad May 19 '12 at 13:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.