Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Just a few months ago, I bought the latest 2011 MacBook Pro. Now, a few months later, I have a problem. It seems like my notebook is rejecting my hard drive (which is an SSD).

How it all began: yesterday, business as usual, I wanted to log in. After typiing my password and pressing enter, something strange happened. OS X was loading, and loading, and loading, till finally it froze (or gave an error, don't know for sure). But anyway, I couldn't get in, so I restarted my laptop. But it didn't start, it just hung with a no-entry directory. At home, I started to search on the Internet. I repaired my disk, several times. When I inserted another hard drive in my laptop, it worked. When I put my SSD in another MacBook, it works. When I plug my SSD externally to my MacBook, it works. But when I put my SDD inside in my MacBook, it doesn't work.

Has anyone had experience with this problem and know how to solve this without a reinstall?

share|improve this question
    
The other Hard Drive you plug in the MacBook is a SSD too? What are the specifications of the failing SSD? Is this the first time it does something weird ? –  Thecafremo May 17 '12 at 7:51
    
When I say HD, it is not a SSD. SSD is a Vertex 3. This is the first time. –  Timo M May 17 '12 at 16:15
    
I have tried everything, also reinstall. Still nothing. I think the problem lays with SATA 3. The SSD works in other computers. –  Timo M May 17 '12 at 16:16
    
Thats exactly what I was thinking of. –  Thecafremo May 17 '12 at 16:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.