Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Late 2008 MacBook Pro that got a new HDD, top case, and RAM within the last week. The previous HDD failed and was replaced by Apple. Using Carbon Copy Cloner and restoring various directories manually to my home folder from Time Machine, I was easily and quickly able to get the computer back to what I believed was its state at the time just before the HDD failed. Now, however, Time Machine is not working properly at all. The incremental backups, which previously were running at what I would consider excellent speed (most were small, in the KB range) took seconds. Now things are much different.

The backups that have run take an average of about 2.5 hours a piece, and run one followed immediately by another. Each of the last four backups shows roughly the same number of files (255,000 - 277,000) being copied by Time Machine. I assure you I am letting the machine sit and no files are being changed by me. After each backup, Time Machine then goes and either deletes expired files (which so far have been backups just over a month old) or performs post backup thinning. It initially performed consecutive full backups, eating up > 100 GB of my backup, and now is doing smaller ones that take roughly the same amount of time. What's more, after each of the last four backups, I have seen an increase in available space on the backup partition, which is less than 1/2 full. There are actually several other problems, but the details are less important than the big picture, which is that Time Machine is clearly not indexing and backing up properly.

Please see the most recent backupd log below (note that these do not show the increase in space that Time Machine is reporting via System Prefs):

May 16 00:46:32 Howard[441]: No pre-backup thinning needed: 107.5 MB requested (including padding), 115.28 GB available
May 16 01:11:31 Howard[441]: Copied 277591 files (80.0 MB) from volume Metal.
May 16 01:20:49 Howard[441]: No pre-backup thinning needed: 100.0 MB requested (including padding), 115.11 GB available
May 16 01:42:56 Howard[441]: Copied 258313 files (502 KB) from volume Metal.
May 16 02:10:37 Howard[441]: Starting post-backup thinning
May 16 02:12:36 Howard[441]: Deleted backup /Volumes/C3PO/Backups.backupdb/Howard Buddin/2012-04-02-114830: 115.16 GB now available
May 16 02:12:36 Howard[441]: Post-back up thinning complete: 1 expired backups removed
May 16 02:12:37 Howard[441]: Backup completed successfully.
May 16 06:00:33 Howard[774]: Starting standard backup
May 16 06:00:33 Howard[774]: Backing up to: /Volumes/C3PO/Backups.backupdb
May 16 06:09:53 Howard[774]: No pre-backup thinning needed: 100.0 MB requested (including padding), 115.16 GB available
May 16 06:32:39 Howard[774]: Copied 277591 files (610 KB) from volume Metal.
May 16 06:41:51 Howard[774]: No pre-backup thinning needed: 100.0 MB requested (including padding), 115.06 GB available
May 16 07:04:16 Howard[774]: Copied 258312 files (526 KB) from volume Metal.
May 16 07:22:43 Howard[774]: Backup deletion was canceled by user
May 16 07:22:43 Howard[774]: Starting post-backup thinning
May 16 07:22:44 Howard[774]: Backup completed successfully.
May 16 12:59:45 Howard[296]: Starting standard backup
May 16 12:59:46 Howard[296]: Backing up to: /Volumes/C3PO/Backups.backupdb
May 16 13:02:10 Howard[296]: Backup canceled.

I have tried repairing the disk, deleting the prefs file, and a few other things on to absolutely no avail - the only thing that hasn't worked is deleting the .Spotlight-V100 file, which gives me the message that it is in use and can't be deleted. I have not removed it (yet) with rm -rf /path/ but am tempted to.

So far I have not found a good solution to this problem. Should I just wipe and reformat, losing my backups or does someone have a solution to this??

share|improve this question
What does the Console have to say? Specifically, log messages from backupd – kopischke May 16 '12 at 19:09
Glad you asked. I just posted it over on the apple support community. My post is edited to include this now. – soxman May 16 '12 at 23:50
@soxman: Are there any updates here? I'm having a very similar problem... – Dror Oct 28 '12 at 8:16
@Dror I followed many threads over the past few months trying to resolve this, and implemented many changes, which at first would work but fail, ultimately, within a couple of days. A post I read the other day on Apple community pages sealed the deal: the problem is apparently a 10.6.x bug that will not be addressed by Apple. I bit the bullet last week and made the move to 10.8.2, and backups are lighting fast, just like they used to/should be. Wish I could help in another way, but that is apparently the official word. – soxman Oct 29 '12 at 4:34
Here: is an example of one iteration of TM. Does this look familiar? – Dror Oct 29 '12 at 5:46

Try turning off Spotlight indexing by putting the Time Machine volume into the list of non-indexed folders in System Preferences.

share|improve this answer
No dice - although not listed in the OP, my Time Machine volume was excluded from Spotlight indexing. Thanks for the suggestion though! – soxman Sep 25 '12 at 4:46
up vote 0 down vote accepted

As it turns out, the only solution seemed to be repartitioning the drive and starting from scratch. Time Machine now works as it should.

Never mind, this did not work, and I am continuing to have the same problems. The initial backup went perfectly well, but all incremental backups continue to loop twice (one backup, immediately followed by another) and take between 2.5 to 3 hours apiece and copy nearly the same number of files as each preceding backup: about 277,000 for loop one, and about 250,000 for loop two.

The problem is apparently a 10.6.x (I believe it is only versions .7 and .8) bug that will not be addressed/fixed by Apple. I installed 10.8.2 last week, and backups are once again normal: fast, with no outrageously large numbers of files copied with each backup. I hated ditching 10.6, as it is an exemplar OS, but I couldn't tolerate another day of Time Machine nonsense.

share|improve this answer
Can you provide some reference? Is this bug somewhere documented? Did you have to make a fresh install, or was the bug fixed after a simply update? – Dror Oct 29 '12 at 5:33

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.