Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

After upgrading to Lion, I cannot connect via SSH. I get a timeout:

$ ssh -o ConnectTimeout=5 not.my.actual.hostname
ssh: connect to host not.my.actual.hostname port 22: Operation timed out

In /var/log/appfirewall.log I get this:

Firewall[541]: Deny sshd-keygen-wrapper connecting from 192.168.1.1:49380 to port 22 proto=6

I have specifically added sshd-keygen-wrapper to my firewall rules and set it to "Allow incoming connections", but I still get the same message in the firewall log.

If I disable the firewall, I can connect without issue, but I'd rather not disable it completely. What am I missing? Thanks.

share|improve this question

1 Answer 1

I was having the same problem and this is how I fixed it --

  1. Delete sshd-keygen-wrapper from firewall list
  2. Click + to add it back
  3. In the Open dialog press Cmd-Shift-G and specify /usr/libexec
  4. select sshd-keygen-wrapper

Explicitly adding it in this way worked for me. Good luck!

After step 4. you have to reboot. Or just restart the firewall by disabling and enabling the firewall in the system settings. Without the restart the new configuration will not be activated.

share|improve this answer
    
Thanks, but as I said, I already tried that. –  Jared Beck Jun 2 '12 at 18:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.