Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Recently when I'm away from home, my MacBook Pro keeps displaying the following message "There was a problem connecting to the server" and the name of my AirPort Extreme with a hard drive connected.

I'm running OSX 10.7.4, and it's only done this for the past two weeks or so.

The only thing I can think of which has changed was the 10.7.4 update itself.

It's quite irritating, but doesn't actually harm anything. Any idea how to stop it happening though?

share|improve this question
    
Why do you think this has anything to do with Time Machine? Did you have a Finder window open for the hard disk connected to the APEx? –  patrix May 18 '12 at 13:38
    
I have a separate NAS which I store files on, and a media centre which I regularly copy movies to, and neither of these network locations pop up with the error. Only the drive connected to the APEx, and this is purely used for Time Machine, nothing else. I never access it as a network drive via finder, so my assumption is that it's something to do with this. I could be wrong though, but it seems odd it only occurs with this 1 location. –  AlanJC May 18 '12 at 16:55
    
Disabling Time Machine, or using TimeMachineEditor to schedule backups stops this error so it's definitely that to blame. I've seen a few posts elsewhere since the 10.7.4 update but obviously it's not common enough to have gained a lot of attention. Would love to solve this issue without having to fall back on disabling things or scheduling things though. –  AlanJC May 24 '12 at 13:10
    
Update: TimeMachineEditor and TimeMachine Scheduler both delay/schedule backups, but both cause the backups to fail when enabled via themselves. If I manually back up, it works fine. I definitely don't get the error connecting to the drive if Time Machine is disabled though, but I've never had this problem on Leopard, Snow Leopard, or Lion prior to 10.7.4. –  AlanJC May 25 '12 at 8:38
    
Is TimeMachine working completely normally when you are connected to your home network? Does your AirPort have a common name (e.g. "AirPort") that matches the name of another AirPort you use? Are you getting an error saying URLs with the type "file:" are not supported? Are you using DropBox? –  Old Pro May 25 '12 at 8:50
show 2 more comments

2 Answers

up vote 2 down vote accepted
+100

I have done two things in this case.

1) Connect a hard drive to change the destination - even if I don't connect that drive often, the local drive check seems faster than a network check. You can then re-establish the network backups to no ill effect when you return home. Having many Time Machine destinations is nice to have a second copy and works well for me.

2) Log into your Time Capsule and sign in again to MobileMe / iCloud and then delete that "find my mac" functionality. This seems to lessen the Time Machine "seeing" the remote drive but has an obvious downside of not being able to re-connect as well to your "home" AirPort / Time Capsule while on the road.

For advanced debugging, you could also run tm_diagnose and pore over the logs collected to see if any error conditions are present in the extremely undocumented and verbose logs that the diagnostic command collects. I would caution people without a UNIX or software background that "errors" in system logs are often not errors in the sense that something is broken - but more for the people who write and maintain the code to remember to clean some thing up or a minor "assumption" was not proven out in practice. There can be lots of false positives when looking at unix logs, but also a lot of learning how things work under the hood.

share|improve this answer
    
I'm going to try number 2 as I never use back to my mac, but I had it signed in! Will get a chance tomorrow or Tuesday :) –  AlanJC May 27 '12 at 10:26
    
Removing the account for back to my mac seems to have done the trick which is confusing me now, ask I don't understand how this changed anything on my MBP itself?! –  AlanJC May 28 '12 at 11:50
    
Finder and OS X will connect to iCloud if you enable that function in system preferences. You also might be able to disable this "seeking" in the finder preferences for the sidebar and the desktop to not show BTMM. In this case, your Mac was already looking and the TimeCapsule completed the chain to let your mac find it through iCloud. –  bmike May 29 '12 at 15:07
add comment

If you're away for an extended period of time, you could just turn off Time Machine until you get home.

share|improve this answer
    
I know I could do that, but it's not really a fix, just a work around. –  AlanJC May 18 '12 at 6:52
    
I wouldn't turn it off - especially if you have local time machine snapshots enabled. That can save you from accidental deletions and also keep revisions of files that don't use the new system revision control scheme. –  bmike May 26 '12 at 17:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.