Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I had that option before and the recent update messed all my settings up:( now I can't hide my texts. I don't want people at work seeing my texts. I have my phone locked but everyone still can read them. I also don't have the option hide preview which was there before!

share|improve this question

In iOS 5, go to Settings > Notifications > Messages. Turn off 'View in Lock Screen'. It makes it so that iMessage/text message notifications don't show up on the lock screen.

share|improve this answer
    
I believe it actually says "Show Preview". So it should be Settings > Notification Center > Messages > Uncheck Show Preview – Ben Holland Jul 9 '15 at 5:11

protected by bmike Apr 17 '15 at 2:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.