Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

On OSX Lion, iTunes keeps prompting me to enter my username and password to "sign in to enable this computer for automatic downloads." In the past I tried checking the box to remember my password but it kept forgetting, so now I just disabled the "always check for available downloads" option in Prefs -> Store. It still prompts me. It drives me crazy.

Is there a way to get it to stop prompting for my password, so it will just behave like a well-behaved offline music library manager, and only ask me for my username and password when I open the iTunes store?

share|improve this question
add comment

4 Answers 4

up vote 2 down vote accepted

All you need to do is Sign OUT of the itunes store!

If you are signed in, each time you fire up iTunes, it will try to login again and ask for your password. Sign out and it won't bother you!

share|improve this answer
1  
But then the automatic download will stop working as well, doesn't it? –  patrix Oct 14 '12 at 10:27
    
I haven't tried this b/c my preferences have changed; I now want to stay signed in w/o having it prompt for p/w. But I'll accept this answer since it seems logical and meets the terms of the original question. If anyone tries this and it doesn't work, please let me know.... –  Philip Oct 18 '12 at 21:25
add comment

Try to resetting your warnings, as suggested in this thread:

Open iTunes/preferences/advanced, then hit the box in the middle that says "reset warnings".

share|improve this answer
    
I tried this + resetting the iTunes Store cache, and so far I have not been prompted for my pw. I will continue to monitor the behavior for a week and if after restarts, device connections, etc. it still doesn't repeat, accept your answer. Thanks! –  Philip May 13 '12 at 21:28
    
After syncing my iPad, it has again started prompting at startup at least once per OSX login session (not sure if more per session). Any thoughts? –  Philip May 19 '12 at 0:01
    
If it is just promting once, perhaps removing the device association in your Apple count may work. –  Thecafremo May 19 '12 at 8:31
    
I get the same behavior. It prompts me for pw at least once per OSX session, and at most once per iTunes session; I'm not sure if many times across iTunes sessions in a single OSX session. –  Philip Aug 10 '12 at 13:16
add comment

This sounds like you might have duplicate iTunes password entries in your keychain.

  1. Open your Keychain.app and search for entries with "iTunes" in it
  2. delete those iTunes entries (you need to know your passwords!)
  3. reboot (to clear out your cache)

Now try again.

share|improve this answer
    
Nope, just one... –  Philip Jun 4 '13 at 12:39
    
Since the problem somehow seems ro be related to your iPad sync, I would try and do a complete backup/restore cycle of that iPad. –  OvQ Jun 8 '13 at 21:53
    
Ahh, good thought, but the problem has persisted over a year of neither having nor syncing an iPad. –  Philip Jun 9 '13 at 19:13
    
Well, then I am slowly running out if options :-) Do you know PowerTunes? It's an iTunes Library manager and maintenance tool. You might want to give it a shot. They charge 19.95 U$, however, there is a trial version. Maybe it can do some magic by rebuilding your iTunes Library... –  OvQ Jun 9 '13 at 23:22
add comment

Possibly sign out of iTunes store, then click "Deauthorize This Computer" under store tab in menu bar, then reauthorize your computer, then sign back in to iTunes store.

share|improve this answer
    
I know this is for MacOS, but I was having the same problem under Windows 7, and this is the only suggestion that actually worked for me. –  Heptite Sep 20 '13 at 19:33
    
I spoke too soon. After a couple of days the problem came back. –  Heptite Sep 23 '13 at 23:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.