Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I recently purchased the new iPad (WiFi) for my mom (Actually, my brother purchased it in USA and shipped it to India). I have a iPhone 4S. They created a contact with my name, added my number (I live in UK, in the following format +44 7XXXXXXXXX). I have created a contact called Mom on my mobile with her Apple ID (i.e., the email address).

When I create a new message...I am able to pick the contact and Message turns to iMessage. The "Send" button turns from (hulk) green to (blue). I send a message. It is sent, but I do not get a delivered report.

When my mom creates a new message, she is able to pick my contact and Message turns to iMessage and "Send" turns from (hulk) green to (blue). However, it fails and comes up with the red exclamation mark.

Any ideas what could be the problem?

share|improve this question
    
Which model is your new iPad? –  JMK May 30 '12 at 17:47
    
The new iPad, 3rd Generation. –  Kanini Jul 19 '12 at 20:57

1 Answer 1

Try turning off iMessage in Settings, reboot the device, and turn on and log into iMessage again. This should re-register your device with Apple's iMessage servers, and may resolve your problem.

This has fixed a similar issue for my iPhone in the past.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.