Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I do use a SSD+HDD setup on MBP but from time to time Finder is trying to access files from the HDD and is waking it up.

I'm not saying about usual cases, this happens even when I do nothing.

Doing a lsof |grep /hd/, hd being the mount name of my hdd shows me that Finder is the cause.

Also, I do not want to disable Finder for the entire drive, and btw, I heard that this could not be the solution.

sorin@sPro ~ $ lsof|grep /hd/
iTunes      269 sorin   24r     DIR               14,5       136   397463 /Volumes/hd/sorin/iTunes Media/Automatically Add to iTunes.localized
iTunes      269 sorin   25r     DIR               14,5       442   397461 /Volumes/hd/sorin/iTunes Media
iTunes      269 sorin   26r     DIR               14,5       306 13961723 /Volumes/hd/sorin
Finder      276 sorin   18r     DIR               14,5       204 14556315 /Volumes/hd/Backups.backupdb
Finder      276 sorin   21r     DIR               14,5       170 16025097 /Volumes/hd/sorin/Movies/boxoffice/The.Iron.Lady.2011.720p.BluRay.x264-Felony
Finder      276 sorin   24r     DIR               14,5      2380 13959970 /Volumes/hd/.Trashes/501

share|improve this question
    
I'm guessing the HDD is an external drive? Also, what files does lsof show as being accessed? –  walker May 19 '12 at 14:21
add comment

1 Answer

up vote 3 down vote accepted

The files are being accessed in read-only mode - the r in the fourth column, the file descriptor column, indicates this.

Is this a media and/or backup drive of some sort?

In any case, I believe Finder is opening those directories because the volume is mounted. Even seemingly innocuous actions may call Finder to wake and read the drive, such as opening a file browsing dialogue in another application.

You may try removing from the Sidebar of Finder any folders on that drive. Also go into Finder's preferences, go to the 'Sidebar' tab, and uncheck either 'Hard Disks' or 'External Disks' under Devices, depending on whatever drive this is. That might prevent Finder from calling the drive.

enter image description here

Barring that, you may try try checking off Put hard disk(s) to sleep when possible in the Energy Saver's preference pane, which will keep the drive awake perpetually, and avoid pauses while it wakes.

enter image description here

You may also want to run ps -ef to check and see if there are any background processes that may be indexing or calling the drive.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.