Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I don't like how in Finder, you can drag a folder and drop it anywhere, even overlapping on another folder. For example:

enter image description here

That is just annoying. And when I resize the window, the files stay how they were (like the files don't reorganize to fit in the new size of the window).

I do realize I can right click and select "Clean up", but I don't like having to do that every time I drag and drop a folder/file.

I know about the setting to make everything "snap to grid" so it will stay organized in the "Show View Options":

enter image description here

However, it only works for that specific folder and does not work across the whole Finder like I want it to. Is there any way to make it apply across everything in Finder?

Also I tried clicking "Use as Defaults" but that only applies to newer folders created I think.

share|improve this question
1  
The key may be as simple as Relaunching Finder. –  E1Suave May 5 '12 at 2:48

1 Answer 1

up vote 16 down vote accepted

The following steps applied "Snap to Grid" even for previously created folders.

Tested on:

  • 10.6.x
  • 10.7.3
  • 10.8.x
  • 10.9.x

    1. Go to any folder control
    2. Control click on the empty space
    3. Click on Show View Options
    4. In the "Arrange by" drop down bar select "Snap to Grid"
    5. At the bottom of the window click on the "Use as Defaults" button

NOTE: Because this will become the default setup for ALL Finder windows you may consider manipulating the Icon size, Grid spacing, Text size, Label position, Background, etc... accordingly.

ALSO: If folders do not appear to have snapped to grid on a previously created folder, Relaunch Finder or you could try to toggle the "Icon size" down and back up too refresh the current window.

share|improve this answer
    
@Nathan Did you have any luck after trying the answer above, or is it still not functioning? –  E1Suave May 16 '12 at 16:57
    
It worked, thanks! Sorry, I just forgot to come back and click the accept button :) –  Nathan May 17 '12 at 1:55
    
@Nathan No problem I am just glad it worked for you. :–) –  E1Suave May 17 '12 at 1:56
2  
works in 10.8 and 10.9 to, tested –  user66396 Jan 3 at 23:43
    
Worked great. Thanks a lot. Quick easy fix. –  user73665 Mar 21 at 3:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.