Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

whenever my computer (which is a MacBook Pro bought in 2012) is sleeping or off, and i login with my password, it is always on a different wifi then my home wifi. My home wifi is Skritty, and the wifi my computer is always on is BronzeMaple-Guest. I just waited 10 minutes for a software update and when it turned on, it went to the BronzeMaple-Guest login website and it totally lost my software update. I was trying to play MineCraft and had to update Java so i could play it. IF YOU HELP I WILL BE VERY THANKFUL!

sincerely, Braden

share|improve this question

2 Answers 2

Click on "advanced" in the Wi-Fi settings then, in the list under "preferred networks," you can rearrange the order of priority as to which networks you'd prefer to connect to if possible

share|improve this answer
2  
Just in case, the wifi settings are in System Preferences > Network. –  John Rygielski May 4 '12 at 21:32

This happens to me a lot. The problem is that there wifi is public so when you wake your computer it connects to the public wifi first. You can edit the wifi-settings and can even block this wifi connection if you want in Network settings.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.