Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I own a Japanese version MacBook Pro, that of course has the Japanese keyboard with the particular keys (around the space bar) that are used to switch between the various forms of Japanese (and English) language input. This is running OSX Lion FYI.

My problem is that the machine sometimes seems to switch into Japanese input mode even when no one has touched the input mode switching keys. This is issue also happens on my wife's MacBook running OSX Snow Leopard and a friend's iBook running Leopard, all of these being Japanese model machines.

Does anyone know of a way to force the OS to ONLY switch the input language when someone actually chooses it from the actual pull down menu?

Perhaps all three of us are hitting the input keys by mistake (i highly doubt that though). If that is the case then it is a design flaw.

Any input (non-Japanese :) would be greatly appreciated.

share|improve this question
    
If a Japanese layout was chosen as the default when OS X was first set up, it could be selected for example on the login screen. You could try running the Setup Assistant again with sudo "/System/Library/CoreServices/Setup Assistant.app/Contents/MacOS/Setup Assistant". –  Lauri Ranta May 4 '12 at 10:09
    
The layout is Japanese since this is a Japanese keyboard (there are several extra buttons which we need). I really do not want to change my keyboard layout. I just want to stop OSX from switching from English input to Japanese input unless someone chooses that option from the drop down list. –  Kevin R. Marshall May 4 '12 at 10:39
add comment

1 Answer

Language & Text

Could it be that you are accidentally hitting the input source switching shortcuts? If so, you can disable them in the System Preferences.

Also, if you find that the input language changes when you switch apps, this is actually normal behavior. By choosing “Use the same one in all documents” in the input source options, you can greatly decrease the chances of this happening. (With the exception of a few apps that seem to ignore/override this setting. Very annoying.)

If you've experienced this problem only when using Japanese keyboards, then I guess there is a different cause. I use US keyboards, but this unintended switching happens to me too. Mostly when switching to Adobe apps.

share|improve this answer
    
Thanks for the input, but we already have "Use the same one in all documents" chosen. I have already disabled the input source shortcuts as shown above but that does not affect the input source key on the Japanese keyboard. It still switches if anyone hits it. –  Kevin R. Marshall May 13 '12 at 10:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.