Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a non-admin account (Standard account) that I normally use on my iMac. For the past 2 days I have been having a really strange issue.

If I search for "Chrome" or "Firefox" on spotlight, finder crashes and relaunches. Everything else, I can search fine. And I only need to type the first few letters (i.e. I type in Ch, the results show up momentarily, but finder relaunches before the logo for Chrome can be loaded. Same with Firefox)

I can open all folders except the Applications folder from Finder. That also results in a crash. This leads me to believe there is some issue in the icon for Firefox or Chrome being rendered.

I tried:

  • reinstalling Chrome and Firefox (deleted their profiles etc). But that does not help.
  • deleting com.apple.finder.plist and relaunching finder, but no good.

Also this happens only on the non-admin account. I can do everything fine on the Admin account.

I can post the crash logs if it helps.

I'm using Snow Leopard.

share|improve this question

closed as unclear what you're asking by bmike Jan 6 at 21:16

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

    
You could try is to repair your permissions since it's most likely the problem. I've knowledge of a similar problem I once stumbled upon. The issue was one "bad" program causing the entire Application folder to crash. It's discussed on the MacRumors discussion forums. It's the last but one reply which holds the solution. –  Michiel May 2 '12 at 7:17
    
That doesn't help. Repaired disk permissions. Also tried changing the Finder view to not show icons. But Finder still relaunches when opening Applications folder. Any other suggestions? –  lostInTransit May 2 '12 at 8:52
    
Not for now, no. Sorry. I'll keep looking! –  Michiel May 2 '12 at 9:29
    
Thanks for the tip though. –  lostInTransit May 2 '12 at 11:19
    
Is this anything that is ongoing or ever resolved? It seems likely it was a filesystem corruption that a wipe and reinstall would fix, but if the problem doesn't exist, we might not be able to conclude what was wrong. –  bmike Jan 6 at 21:16