Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Whenever I reopen Pages or Numbers, all documents that I had open when I last exited are reopened. I have the "restore windows" checkbox unchecked in System Preferences > General, but all windows from my previous session are always reopened every time I re-launch Pages or Numbers. Is there a way to force iWork apps to behave as expected?

share|improve this question
    
What I have done in other apps, like Firefox, is to close all windows before quitting the app. –  Dave Nelson May 1 '12 at 17:42
    
@DaveNelson: That's not really my question. –  raxacoricofallapatorius May 1 '12 at 17:56
    
Could you provide us with the iWork version you are running, as well as the OS X version. Also, what “Settings” are you speaking of? iWork’s? Or OS X’ System Settings? –  kopischke May 1 '12 at 18:16
    
@kopischke: Versions are all (always) current. –  raxacoricofallapatorius May 1 '12 at 19:32
add comment

1 Answer

up vote 2 down vote accepted

Judging from Apple Discussion threads (a quick search turned up these three threads on the first page of results alone), the global Resume switch does not seem to consistently stop applications from saving and restoring Saved State information.

If you only want to disable Resume selectively for iWork, you may be best served by something like RestoreMeNot or TinkerTool, which has a dedicated tab for granularly managing Resume besides its other tweaking features.

If you want to completely disable the Resume feature, Mac OS X Hints outlines a procedure to do so. I can’t judge on it, nor recommend it, as it is altogether too hackish for my taste – the editor’s label “proceed at your own risk” applies.

share|improve this answer
    
So is it the case that iWork apps are among those that ignore the system-wide setting and always save window state (with no UI for changing that)? –  raxacoricofallapatorius May 2 '12 at 13:33
1  
@raxacoricofallapatorius: looks like it, considering your difficulties. Does disabling them on a per-app basis solve the issue? –  kopischke May 2 '12 at 13:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.