Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have an iPhone (iOS 5.1). I added a new telephone number to a new address book entry yesterday and today I find that neither the iCloud Web interface nor my address book on my desktop (OS X 10.7.3) know anything of the new entry.

I was used to automatic syncing via the Internet from MobileMe. Does it not work like that with iCloud?

(Calendar syncing appears to work. Both calendar and address book are switched on on both the iPhone and the iCloud control panel on my desktop.)

share|improve this question
    
Have you successfully synced contact information in the past, and now it's not working? (i.e. you've set up iCloud and now it's malfunctioned) Or is this the first time you've changed contact info since using iCloud (iCloud may not be configured correctly - e.g. it can be set to not sync Contacts)? –  Dan J May 1 '12 at 15:46
    
Not sure if it has worked in the past, after I switched to iCloud two weeks ago. But iCloud is set up to sync contacts on both the desktop and the phone and it is syncing contacts between the desktop and the cloud/Web. –  Andrew J. Brehm May 1 '12 at 16:52
add comment

1 Answer

In your Macintosh Address Book, go to Preferences/Accounts and make sure that iCloud is listed there and enabled.

After doing that go back into Address Book and Click on the red bookmark so you're looking at the front page. It should say "iCloud" at the top of the list of folder/groups you may have there. If it says "On My Mac" then see if you can choose "iCloud."

The design of switching between "on my mac" and "iCloud" is confusing for us "old" mobileme users and my guess is it will change in time.

share|improve this answer
    
Hm... I have to check that tonight. But the problem went away on its own. After I had added a few more addresses on my Mac, the entire thing suddenly synced. It was over a day late but it worked. Still don't know why it didn't sync for a day. –  Andrew J. Brehm May 2 '12 at 11:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.