Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Until recently, I left my iMac (27" late 2009) on all the time. I now want to sleep it when not in use, but also wake it remotely via my AirPort Extreme. All this is working fine. The iMac is set to sleep after 6 minutes.

I have an AppleTV 3 and when powered on (but sleeping) it causes the iMac to wake every ten minutes. greping for wake in system.log shows a bonjour service connection approximately every 10 minutes. After lots of mDNS debugging I narrowed it down to the AppleTV (there are iPads and phones and other Macs around, it wasn't my first thought). Unplugging the AppleTV proved this - the iMac has been asleep for 8 hours now.

I do have home sharing enabled. This is pretty much all it's used for.

Has anyone come across this before and know what's going on?

share|improve this question
    
Have you tried unchecking "Wake for network access" in the System Preferences >> Energy Saver? –  badams Apr 30 '12 at 21:47
    
Yes, and that does work to stop the iMac waking. But I still need to be able to wake the iMac remotely so it is not a solution. –  nOw2 May 1 '12 at 11:44
    
I switched my Apple TV from Ethernet to wifi and so far no unnecessary wakes. Could it be a simple wired Ethernet bug? Can anyone else try this or confirm? –  nOw2 May 10 '12 at 17:33
    
My AppleTV has been on wifi from 9th-16th and has not once unnecessarily woke my iMac. This fix works with 5.0.0 and the new 5.0.1 (installed on the 11th). I will confirm if 5.0.1 has any effect on ethernet and write an answer confirming my findings. –  nOw2 May 16 '12 at 12:03
add comment

2 Answers

up vote 0 down vote accepted

Switching my AppleTV 3 to WiFi has proven to be a valid solution to this.

I am unsure if the issue with wired networking is with the AppleTV itself or my network, but suffice to say for now that the network doesn't cause any other noticeable problems.

share|improve this answer
add comment

After Apple TV Software Update 5.1, I comfirmed this issue was resolved. Try to update your FW!

The following my old comment is for old FW. I leave it just for knowledge.

I had have same problems. I know Snow Leopard's mDNSresponder wakes a Mac every 2 hours during sleep. So a similar thing occurs on AppleTV every 10 minutes, I guess.

In my case, AppleTV woke my Mac If I set Home Sharing on it. So, 1st option is disabling HomeSharing.

However, I didn't want to do that. So now I avoided this to kill iTunes before Mac sleep. This means it doesn't register Home Sharing service for sleep proxy.

Note: 1. You have to wake up your Mac by some method(http, ssh, magic packet or something) when you want to use your Home Sharing. 2. You cannot use sleepWatcher to make 2nd option because it's too late for killing iTunes after sleep trigger. So you must check IDLE time and sleep timer.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.