Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

This question already has an answer here:

In the past when I have plugged in external hard-drives they would always show up on the desktop. I'm not sure if it is because of a software update or the drive itself but it's no longer showing up.

The drive is working because if I go to Finder I can access the drive.

How can I change the settings so that drives show up on the desktop when they are plugged in?

I'm using OSX version: 10.7.3.

share|improve this question

marked as duplicate by timothymh, bmike Oct 29 at 0:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

up vote 3 down vote accepted

You probably have accidentally unchecked "Hard disks" from the Finder Preference pane (accessible with + , ). Just check the box,

enter image description here

and you should be good to go!

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.