Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I noticed my MBP got really slow, which must be strange with SSD and 8GB of RAM.

So I opened the Activity Monitor to discover a process called ubd keeps its CPU usage very high, about 120% most of the time:

ubd process

I found a thread that discusses the issue but it is related to having hundreds of iCloud certificates in the keychain, which I don't.

Just a few iCloud certificates

How do I go on with diagnosing the issue?

share|improve this question
    
Could you specify which version of 10.7 you're using? –  da4 May 28 '12 at 16:12
add comment

2 Answers 2

up vote 5 down vote accepted

By observing log messages in ~/Library/Logs/Ubiquity/<my username>/, I realized that Ubiquity (iCloud process) kept trying to create a file in a folder that doesn't exist:

ubiquity log

I opened up the Terminal and created this directory and its parent directories up to .ubd:

cd ~/Library/Mobile\ Documents/
sudo mkdir .ubd && cd .ubd
sudo mkdir peer-E2B13E4F-56F7-C79B-1621-E30738B638FE-v23 && cd peer-E2B13E4F-56F7-C79B-1621-E30738B638FE-v23
sudo mkdir ftr

Then I changed the newly created directories' owner from root to myself:

cd ../..
sudo chown -R <my username> .ubd/ 

The fan turned silent instantly.

share|improve this answer
1  
Nice catch. I'll add that, if I'm not mistaken, you can use mkdir with the -p switch to create parent directories as needed on a specified path, rather than combining multiple mkdir and cd commands. :) –  Dan J Aug 7 '13 at 19:28
    
sudo probably isn't required here –  patrix Oct 9 '13 at 4:44
add comment

https://discussions.apple.com/thread/5208590?start=0&tstart=0 :

"Applications that can store documents in iCloud include Preview, TextEdit, Pages, Numbers, Keynote, GarageBand, and some third-party software such as "DayOne," "iA Writer," "MindNode," and perhaps others. If some or all of those applications are suddenly not working well, there may be a problem with iCloud synchronization.

Back up all data.

Open the iCloud preference pane in System Preferences and uncheck the box marked Documents & Data. See whether there's any improvement. If there is, continue.

Hold down the option key and select

Go ▹ Library

from the Finder menu bar. From the folder that opens, move this folder to the Desktop: Mobile Documents (or any other item with a name beginning that way) and move this folder to the Trash: Application Support/Ubiquity Re-enable Documents & Data, log out, log back in, and test. The folders should be recreated automatically. If the issue is resolved, delete the folder you moved to the Desktop.

If you continue to have the same problems, I suggest you contact iCloud Support."

-Linc Davis

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.