Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a lightly used server that no longer will show me the settings for Web services in the server app.

I see the progress spinner when selecting "web" from the list of services - but after a little while, servermrgd logs an error message and I see "Error Reading Settings" displayed where the Server app normally shows the web settings and controls in the main pane.

Here is what's logged to /var/log/system.log when select web...

Apr 25 12:00:32 www servermgrd[15799]: xswebconfig failed: Exception:
    undefined method `downcase' for nil:NilClass
Apr 25 12:00:32 www servermgrd[15799]: servermgr_web:  Error Domain=XSServerFoundationErrorDomain Code=4 "Failed to read settings: Exception:
    undefined method `downcase' for nil:NilClass
    ." UserInfo=0x7fc7c1def3d0 {NSLocalizedDescription=Failed to read settings: Exception:
    undefined method `downcase' for nil:NilClass
    .}

Where do I look next for a clue as to what is wrong or what might need to be fixed so I can resume using Server to manage the web sharing service?

10.7.3 build 11D50b - The server is a pretty simple setup - hosting one domain / one site - isolated server (all in one). The service is running (it serves up web pages), but I'd like to get control back of the settings or at least know what has broken to prevent the Server app from reading the settings.

share|improve this question
    
same problem... –  Meltemi May 22 '12 at 2:39
    
I will try to poke at this some more and see if I can find anything else. Have you upgraded to 10.7.4 yet? –  bmike May 22 '12 at 3:12
    
@Meltemi - also - it's best to up vote questions where you want them to gain attention. Adding a comment helps if there are details to illustrate things, but a simple "Me Too" is what voting is designed to let questions surface that people are interested in seeing an answer. –  bmike May 22 '12 at 3:13
    
yes, i have upgraded to 10.7.4. I think my problem may, actually, stem from an expired self-signed certificate...but I can't "Edit" the certificates in Server.app until the Web Server can read its settings... annoying! –  Meltemi May 22 '12 at 18:46
    
@Meltemi I'm still locked out even at 10.7.5 and have double checked all the certificates used are not expired. Luckily all other functions work, so I'm waiting to see if I ever need to fix this or can let this server go away once I have things ready to move to our new 10.8 server. –  bmike Nov 5 '12 at 21:00

1 Answer 1

up vote 0 down vote accepted

I finally have had the chance to blow away this pesky server and no amount of digging yielded a clue how to avoid a reset of www - so that's what I did. I had since updated it to 10.7.5 Build 11G63 and the errors persisted on managing the web service.

I shut down all services except for File Sharing, DNS and Open Directory and did the following steps to force down apache and force a reset. Even trying to stop the web service using sudo serveradmin stop web kept failing with the errors above about xswebconfig and undefined methods of nil classes.

sudo apachectl stop 
sudo serveradmin command web:command=restoreFactorySettings
sudo serveradmin start web

At this point refreshing the Server app corrected the errors reading the settings. Thanks to this hint on cleaning up apache to get me most of the way to my solution.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.