Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have been an iOS developer for quite some time now, and I am still using Xcode 4.2, because the new version is now only available for Lion. My problem is that after reading the reviews for Lion in the App Store, it looks like Windows ME would be a great OS compared to Lion.

I really would like to code for iOS 5.1 and above which you can only do with the new Xcode, but I really really don't want to upgrade to Lion. Is there any possible way to avoid this?.

I currently own a 17" MacBook Pro with a Core i5 at 2.53 GHz and 4 GB RAM it runs Snow Leopard great, but I am afraid it will have problems with Lion, not only because of the hardware, but because it seems to be full of bugs and is just slower overall.

I suppose I could install both Snow Leopard and Lion?. Any workaround is welcome.

share|improve this question
9  
Let me just say that Lion is not that bad; at least starting with 10.7.2. I was hesitant to upgrade to it, but it works fine for me now. If you look at the reviews most of the issues are PEBKAC or deal with real issues that were fixed by Apple since. –  lupincho Apr 25 '12 at 17:44
1  
I second @lupincho's comment. I, as well, was very hesitant to upgrade, but I will say that I am very happy with the performance of it and I'd highly recommend it. –  daviesgeek Apr 25 '12 at 18:35
3  
You are silly not to install lion. I've had it from day one, no problems. It's definitely faster for me than snow leopard ever was. I have a slightly newer machine spec than you, but not tons better. –  livingtech Apr 25 '12 at 20:13
1  
Well maybe it is not too bad then, hopefully... –  Oscar Gomez Apr 25 '12 at 20:35
1  
I have Lion on my laptop and I like it, but I'm not ready to upgrade my workstation to Lion as there are apps that don't work in Lion that I want to keep using. I'm using a VMware Fusion VM to run Lion on my workstation when I need it. –  Old Pro Apr 29 '12 at 17:59

3 Answers 3

up vote 13 down vote accepted

You really can't. Unless you skip to Mountain Lion. Its one of the blessings and curses of being an Apple Developer and that is that you must stay current, or your out of the game for both iOS and Mac Development.

To use the latest bells and whistles for the next OS releases you are really going to be bound to Apple's software and hardware requirements for those tools, other wise you will find yourself speding too much time hacking together your build tools, instead of making forward progress.

share|improve this answer

Get yourself a copy of VMware Fusion and run your various development OS virtually. As a developer this is a critical step to ensure you have the ability to support older and newer OS without needing dedicated hardware for each image.

On rare occasion you will want to move a specific image to an external drive and boot 100% in that OS (or restore that image on to an internal drive) - but for most situations the penalty for running virtually isn't something that sends a particular setup over the brink to being too slow.

share|improve this answer
    
Thank you for answer, I will look into that, what about installing Lion in another partition?, would that be advisable? –  Oscar Gomez Apr 25 '12 at 17:13
1  
I don't advise it since spotlight will see all mounted volumes and you can accidentally run apps from the wrong /Applications folder. Once you start accumulating a 10.6.8 image and a 10.7.3 image and a 10.7.x image - now you have three or more copies of Safari, Disk Utility, System Preferences around and mounted. Then you need to deal with Time Machine backing up the same data or the App Store wanting to update apps on another OS level just because it can see those apps in spotlight. For me - keeping things virtualized works better than partitioning or running on multiple drives. –  bmike Apr 25 '12 at 17:24
1  
If your running VMware 4 on SnowLeopard host, Lion may not actually be able to be installed as guest. Can't confirm but it looks like VMware does not support runing Lion in a VM on Mac running SnowLeopard as the host. kb.vmware.com/selfservice/microsites/… –  MrDaniel Apr 25 '12 at 17:34
    
@MrDaniel has some good points. In general - once you start down the VM path, you'll want to run the latest OS when your hardware requires it and virtualize the older. Sometimes you can get caught in a jam where one version of X isn't happy with another of Y - but this is a core function of VM software, and as long as you're not trying to run something 10 years apart - the vendors usually patch things to work and any glitches are short lived. –  bmike Apr 25 '12 at 17:38
3  
Despite what the documentation says, you are technically able to create and use a VMware Fusion virtual machine with Lion guest OS on a Snow Leopard host OS with the current version of Fusion (4.1.2). Unlike the other restrictions, this is not something Fusion refuses to do or even warns you about. You just need to have a bootable, retail version Lion DVD. In any case, the restriction is on installing, not on running a VM. As for dual-boot, the 10.6 and 10.7 Spotlights clobber each other, making dual-boot super-annoying. –  Old Pro Apr 29 '12 at 17:54

Dual boot your computer then set each operating system to not automount the other OS's partition. This can be done perhaps like this: http://puremac.wordpress.com/2011/01/30/stop-mac-os-x-from-automounting-all-the-drives/

share|improve this answer
    
Thanks for posting an answer devictories! Can you please summarize the link you posted, as link have a tendency to disappear over time, leaving an answer that isn't helpful for those who may find you answer in the future. Thank you! –  daviesgeek May 23 '12 at 17:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.