Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a gmail account setup as IMAP in Apple Mail and recently some new emails coming through have displayed the plain text version instead of HTML. If I check the same email through gmail.com it shows the HTML fine but back in Mail I can't even change it to HTML under View -> Message -> Next Alternative.

This solution did not work for me: defaults write com.apple.mail PreferPlainText -bool FALSE

I'm running Apple Mail 5.2 on Mac OS 10.7.3

I have just found that the same email message will show HTML when viewed in the All Mail Folder but not when viewed in the Inbox.

share|improve this question
    
I use the same setup (IMAP, Mail.app, GMail) but don't have this problem. Can you post the Raw Headers of an example email that shows up plain in Mail but HTML in GMail? –  Avery Chan Apr 25 '12 at 12:53
    
Have you done View > Message > Raw Source in Mail and verified that the incoming messages where this happens actually do include the html version when they get to your machine? –  Tom Gewecke Apr 25 '12 at 13:07
    
@Avry I'm only seeing this with some emails e.g. ebay and amazon. The key part of the headers: Mime-Version: 1.0 Content-Type: multipart/alternative; boundary="----=_Part_161163_12044293.1335349020081" –  Mark Robinson Apr 25 '12 at 13:54
    
@TomGewecke Yes, and they do. –  Mark Robinson Apr 26 '12 at 13:16
2  
And for some reason you consider displaying plain text over HTML a bug rather than a feature? :-) –  Daniel Lawson Dec 11 '12 at 20:55
show 2 more comments

2 Answers 2

I opened ~/Library/Preferences/com.apple.mail.plist in Xcode and searched for PreferPlainText. It seems to want either YES or NO as a value.

I set it to NO and saved, then relaunched Mail.app.

HTML (Rich Text) mail is back.

share|improve this answer
add comment

I have a solution for this but not a reason on why it happens. To solve the problem, you must delete the ".OfflineCache" folder found in "User/Library/Mail/V2/IMAP-{youremail}/".

Note the folder is hidden (even Library is hidden), so you'll need to use this terminal command to show hidden files:

defaults write com.apple.finder AppleShowAllFiles YES

You'll need to restart the Finder to make the command work, by the way.

share|improve this answer
    
not working for me –  GJ. Dec 6 '12 at 15:33
    
If you're using Terminal, you might as well just rm -rf ~/Library/Mail/V2/IMAP-{youremail}. –  kuyan Dec 13 '12 at 0:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.