Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a Macbook Pro running Lion 10.7.3. It has an SSD with 2 partitions: the OS is located in partition 1 and my user home is in partition 2.

Everything was working fine, but some days ago I had to restart the notebook and now the OS says that it can not access to my user folders, I cannot navigate (via terminal) to the OS folders, like Library and others.

I've tried many things, including run fsck and Disk Utility's to Repair Permissions but nothing works; what could happened? Suggestions to solve or try?

share|improve this question
add comment

2 Answers

Check in the "User & Groups" System Preferences, it looks like OS X may have somehow forgotten the path to where your "Home directory:" is at.

If you can still login, verify that your Path is still what you set in System Preferences for your "Home directory:" path.

If you can't log in, then try logging in as another Admin user to fix your home directory location.

Try to login as that user and then edit, verify where the OS thinks your home directory is for your primary user account.

Create a new Mac OS X adminstrator account without an existing administrator password might be helpful in your situation, so that you can have another admin account to help you trouble shoot.

  1. Restart the computer in Mac OS X single user mode by holding Command-S at startup.

  2. Mount the computer's drive for read/write access. To do so, type the following command at the command prompt, and then press Enter:

    % mount -uw /

  3. Remove the file that identifies that the initial run of the "Mac OS X Setup Assistant" has been completed, with this command at the command prompt, followed by Enter:

    % rm /var/db/.applesetupdone #Update on Lion it looks like its .AppleSetupDone

  4. Restart the computer by entering this command, followed by Enter.

    % reboot

  5. The Mac OS X Setup Assistant screen should appear after the reboot, just as it does when you start up a brand new computer or upgrade to a new version of Mac OS X.

  6. Create a new user account with the Setup Assistant. Be sure to name this user something different than the admin user that already exists on the system, and use a strong password (see "Mac OS X password tips"). At the end of the Setup Assistant process, the system will automatically log into this new user account. The account will have a unique ID (UID) that is one higher than the last user that was on the system, and will have all administration privileges.

  7. Log in as the new user, and then edit the "Home directory:" Advanced Options path for your primary user.

share|improve this answer
    
Hi, no, I don't have another user, but I can try to log as root or create another one and see what happens.. I've already tried to reestablish the home directory path.. but no luck... the folder "disappeared" ... :S –  Jota Ele Apr 24 '12 at 14:51
    
I'll try to follow your tips at home at night,... The new user should be named the one that I have now (the one that I've lost the home folders)? –  Jota Ele Apr 24 '12 at 14:57
    
No create a separate and different user name, you don't want two user with the same name, this account would be something to help you diagnose issues on your machine and not to replace your current user account. –  MrDaniel Apr 24 '12 at 15:13
    
Interesting, I would try to navigate to where your "external" home directory is and verify that the User ID and Group ID of the folder and all things in it matches that of your primary user account. Does it? –  MrDaniel Apr 24 '12 at 15:22
    
Hi dude!... I've tried your suggestions and I found some interesting things.. I created a new user with admin role and logged in with it.. I can see the lost folders "but" they are in another partition and the group is a different one... I don't know how, but I have another partition, really strange because my ssd does not have free space. it's named "Datos 1" and the original one was called "Datos", I can see both of them, but it seems that the OS not... –  Jota Ele Apr 25 '12 at 13:17
show 5 more comments

Man, I hate it when that happens, and something similar did happen to me a couple of weeks ago - right after I installed my SSD. If Disk Utility sees that partition, there is hope. What I was told by our local Mac guru was that SSD and partitioning don't work well together.

That's not what you want to hear, I know, but you asked for suggestions, so here is what I had to do. Luckily, I had a full backup of everything stored on a server. So it was just a matter of erasing everything on the SSD and then copying the backup file to the SSD. After that, I ran a couple of checks from within Disk Utility, and all was fine.

share|improve this answer
    
Hi dude!, thanks for the tip... 'but' I believe I'm in a better situation than yours.. :) ... I can see the partition, I can get my data and everything is fine, I believe I "just" lost the "Library" folder and so all my configurations, apps, email backup, etc. but personal data is alive... –  Jota Ele Apr 24 '12 at 14:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.