Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

So in my contact list (the native iPhone app for contacts), it has not only my contacts with phone numbers, but also any email address I've ever sent or received an email from. I'd really rather not have the email contacts automatically save into my contact list. Is there a way to stop this from happening?

share|improve this question
    
are you using gmail? –  segiddins Apr 22 '12 at 22:06
    
@SamGiddins I am and I want to solve this problem for that situation. Ay suggestions? –  Yar Jun 13 '12 at 21:21
2  
gmail has an option to automatically add everyone you email to your contacts. turn that off and you should be golden. –  segiddins Jun 14 '12 at 2:12
    
I too was facing the same problem everyone in my address book I pulled the plug on the attempt. But now the email address I used to start the sign-up process is getting flooded with spam, and it started about a week after the sign-up debacle. It may only be a coincidence, but I doubt it. –  user34891 Nov 17 '12 at 10:33
    
Possible duplicate: apple.stackexchange.com/q/29118/8950 –  Redandwhite Mar 5 '13 at 17:31

12 Answers 12

Tap Contacts, Groups , then un-tick 'All yahoo'. that's all

share|improve this answer

Install 'Delete Contacts' App free from the app store > scroll down to smart filters > scroll down and find 'no phone' > click on this and all the contact with no phone numbers will show up > delete them all and > go back to contacts and sync... all done.

share|improve this answer

Let's keep it simple, if you sync with your work Exchange outlook contacts, click on the "Phone" icon on your Iphone, in the upper left corner of the screen click on "Groups", under "EXCHANGE" make sure only "contacts" is checked. If you have "All Exchange" checked, it will load all the email addresses as contacts in your IPhone directory.

share|improve this answer

I was reading all of these and started to follow the path as I too had loads of email junk contacts. Once I opened the Contact page and clicked groups I noticed three choices... All exchanges: Contact: suggested contacts. I clicked the work contacts and the other options no longer have checks next to them. Voila all the junk is gone and only my outlook contacts remain.

share|improve this answer

Go to settings

mail, contacts calendars select your email account you will see the tab contacts switch this to OFF. It will ask you to delete email content in your contact list. Delete it.

Et voila bye bye emails in contact list.

(just FYI - it will delete ALL contacts even the PHONE contacts you have added!)

share|improve this answer

I use my iPhone 5 for work and it syncs with my Outlook on my Windows PC/laptop. When I went to settings and turned off the Contacts switch for the email account it deleted all my contacts. Not a good thing. Instead, I went into Contacts and selected Groups at the top of the screen. I then deseleted Suggested Contacts. Now only the contacts that I input show up and all the random email addresses that I sent an email to once are hidden. They are still there in Suggested Contacts if I want to see them.

share|improve this answer

1) Go to 'settings' --> 'Mail, Contacts, Calendars". Scroll down till you see "import SIM contacts". Click on that to import your phone contacts to your iPhone.

4) On your homepage, click on the Phone icon. On the contacts page, click on the 'Groups' button on the top left. Uncheck all (your email accounts), except for 'All on my iPhone'. Now click 'done', and you're all set! Go to your Contacts app directly and do the same (uncheck all email mailboxes).

If that doesn't work, try doing this:

1) Go to 'settings' --> 'Mail, Contacts, Calendars". Under 'Accounts', access each mailbox and toggle the 'contacts' option to 'off'.

2) On the same page (Mail, Contacts, Calendar), scroll down till you see "import SIM contacts". Click on that to import your phone contacts to your iPhone.

3) Now, scroll back up to 'Accounts' and toggle the 'contacts' option of all the mailboxes back to "on".

4) Go back to your homepage and click on the Phone icon. On the contacts page, click on the 'Groups' button on the top left. Uncheck all (your email accounts), except for 'All on my iPhone'. Now click 'done', and you're all set! Go to your contacts app directly and do the same (uncheck all email mailboxes).

share|improve this answer

Tap on Phone icon. Then tap on contacts. In the contacts page on the upper left hand corner there is an icon named Group. Tap on that and then you come to a page where the heading is : Show all contacts and below that there is All iCloud, All Facebook and All Yahoo etc. Just click on All iCloud and press Done on the upper right hand top corner. You will find all the emails vanish from your contacts and only the phone contacts will remain.

Let me know if it helps.

share|improve this answer

Go to Phone then select Contacts, or select the Contacts app directly. In the upper left corner select Groups, then remove Suggested Contacts from the list of synced contacts.

share|improve this answer

You need to go into your Outlook to your Contact tab and create a folder for business contacts and for personal contacts and separate them accordingly. Then on your iPhone go into your Contacts and hit groups and you can select either folder or both and this should fix your problem.

share|improve this answer
1  
And if the user is not using Outlook at all? Does this still apply? –  Tonin Mar 5 '13 at 18:20

I had the same problem but what i have just done (pure trial and error) is to go into Settings -> Mail, Contacts, Calendar and, on each of your accounts, unselect Contacts, then import SIM contacts.

Voilà! No more random email contacts and all the numbers from your SIM! (Not sure how this will effect your email contacts when emailing but you can always sync them again if needed, I guess!)

share|improve this answer

The iOS email contacts are saved into the Contacts app; so, the only way to remove the email addresses from your Contacts app would cause the email addresses not show up in the Mail app. If you are using Gmail, the official Gmail app could be the solution, but I have not used the Gmail app so I cannot be sure.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.