Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a MacBook Pro with Microsoft Word 2011 installed on it.

For some reason, all the editing keyboard shortcuts - such as Cut: Cmd + X, Copy: Cmd + C, and Undo: Cmd + Z - does not work in it.

My friend who also has Microsoft Word 2011 on a MacBook Pro has his keyboard shortcuts working fine.

This situation really hinders my work, what could be the problem?

share|improve this question

10 Answers 10

up vote 3 down vote accepted

Check in the edit menu and see what MS Word thinks its shortcut keys are for cut, copy, and paste.

If they're not the keys you’re expecting, maybe something was accidentally configured in Word’s preferences, e.g. some alternate key mapping.

Also, verify that there are not alternative key mappings specified in the Mac System Preferences, both system wide and application specific, that may be modifying your shortcut mappings to other keys.

share|improve this answer

If the configuration of the hot keys disappeared from the Edit menu, you can reconfigure them through the menu "Tools", option "Customize keyboard"

share|improve this answer

My keyboard shortcuts for Copy, Cut, and Paste also disappeared under Mountain Lion. Going to Tools/CustomizeKeyboard did not help (the shortcuts are listed under Keyboard Shortcuts but do not show up on the Edit menu).

The workaround suggested above works. In System Preferences/Keyboard/Keyboard Shortcuts/Application Shortcuts, you can add Microsoft Excel (use the + key, then in the Application pulldown menu you might have to go to Other and navigate through the Microsoft Office menu to be able to select Excel). Then I just added cmd-c, x, and v. The keyboard shortcuts still do not appear in Excel's edit menu, but the keyboard shortcuts work as they had done previously.

share|improve this answer

Hmm, make sure you're using the "command" + "C" / "V" / "x" in order to copy, paste and cut and not "ctrl" + the keys.

Macs dont respond to "ctrl" + other key shortcuts.

share|improve this answer
    
I am using the command key.. –  idober Apr 22 '12 at 20:55
1  
wouldn't know then :/ Just suggested that because ive got a mate that had the same issue. –  Thekrazypig Apr 22 '12 at 21:09

Try quitting Microsoft Word (literally quitting...Command+Q) then reopen and see how it goes. It worked for me.

share|improve this answer

I had the same problem, and I found out how to fix it:

  1. Go to "Tools"
  2. Click on "Customize Keyboard"
  3. Choose "Edit"
  4. Choose "Edit copy"
  5. Highlight F3 and remove it, leaving ⌘ cmd+C and press OK.
    The same is for "Edit cut/paste." You just remove the F4/F3 etc.
share|improve this answer

control panel all items language advanced settings (tick) let me set a different input method for each app restart word DONE

share|improve this answer
    
This answer seems to be for Windows, not OS X. –  grgarside Jan 22 '14 at 21:16

Mac-Windows-Word/Excel version: this was my fix

  1. In Word or Excel go to File
  2. Options
  3. Customize Ribbon
  4. Keyboard Shortcuts
  5. In Categories - All Commands

    Then search for CopyText, PasteText etc. If no current keys then Press new shortcut key box and assign the keys wanted

share|improve this answer

[Note: I'm using Cmd- the same as Cmd+ as you don't actually type the hyphen or plus, and Cmd is the "command" keyboard key. I found the problem using Excel with Office 2011, but it may apply to Word too.)

Cmd-C, Cmd-V, Cmd-X and maybe others stopped working and the shortcuts weren't displayed in the menu after I was messing around trying to add Paste->Transpose to the tool bar. (In addition, selecting an area and hitting Cmd-C did not display the crawling-ants indication around the selection.)

Give this a try, and it may work. I had flakey results: go to menu View -> Toolbars -> Customize Toolbars and Menus...

In the window that appears the Toolbars and Menus "tab" is displayed (for me).

Check or un-check "Show ScreenTips for toolbar commands". (That setting is supposed to show what an icon is supposed to do if you hover the mouse-pointer over it.)

Once I UNchecked that box the shortcuts started working again (after "OK" dismissing the window) and the shortcut keys were displayed in the menus.

BTW, "Show shortcut keys in ScreenTips" is checked for me.

Now as I wrote this posting I found out that Cmd-C stopped working again. I went back in and checked "Show ScreenTips for toolbar commands" and Cmd-C started working again. And after more experimentation no matter if I check or un-check "Show ScreenTips for toolbar commands" I can't get Cmd-C to copy. (However the Edit menu does show that Cmd+C does "copy to scrapbook".)

So I exited Excel 2011 and went back in and all the shortcuts are again working and "Show ScreenTips for toolbar commands" is un-checked. I checked it and the shortcuts continue to work and hovering over an icon displays what function it's supposed to perform.

Therefore, the above may or may not work for you.

I still haven't found a way to make a transpose tool bar shortcut, although I read in another forum that Cmd-E is supposed to paste->transpose, but it doesn't for me. (You can get transpose if you use the Home tab's Paste ribbon pull-down but I'm trying to avoid mousing.) I might have to make a macro for it.

share|improve this answer

I have MBP with MSO 2011 also and had same problem. Use "control" instead of "command" works.

share|improve this answer
    
Hi, please edit and expand on your answer. Where a one line answer may contain a correct solution it will not in most cases provid enough information to reach it. Your answer does exactly that. It also does not in it's current form address the specific question. –  markhunte Feb 10 '14 at 4:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.