Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I just installed a new AirPort Express today, and connected a MacBook Air and an HP EliteBook to it.

While browsing the web feels, to use an unscientific term, sluggish, I could verify serious latencies when pinging the computer from each other.

While sometimes the latency is as low as 2ms, most times it is around 300ms, spiking randomly even higher, and timing out from time to time.

This article suggest switching to 802.11n exclusively and setting the Multicast Rate to 2 Mbps.

While I tried changing the Radio Mode with no real success, I don't have an option to the the Multicast Rate on my device (Firmware 7.6.1).

When did this option disappear (or has it never been included in European models), and what other settings could help get the latency down?

Update: Using the trick from this question I got the response times down, and will now test how it helps with real usage:

sudo ping -i .2 192.168.1.1

Update 2: Even using the ping trick, I sometimes get timeouts from the the Windows machine and single digit packet losses. Sadly the performance is still very inconsistent, and I couldn't yet nail the cause down.

share|improve this question
    
What are you comparing performance to? Another AirPort that this one replaced? A different router? –  Nathan Greenstein Apr 21 '12 at 18:44
add comment

2 Answers 2

The Wireless Diagnostic Tool that come with OSX is a great resource for finding out what the cause of your problem might be and it even suggests you the best channels to use based on your scenario (interferences of other wi-fi networks, for example). There is a video tip on TUAW on using it. Best of luck! :-)

share|improve this answer
add comment

The problem could be a huge amount of interferences produced by other Wi-Fi networks in the same band, 2.4Ghz band is shared by a lot of technologies (from DECT phones to Bluetooth and WiFi) and depending your area,neightbours and the way your building have been built, you can get a lot of issues like this.

In those situations i recommend switching to cable, it will always give you maximum performance if you are most of the time in the same place.

Another option will be to switch the band to 5GHz which is lot less crowded and much robust in terms of interferences, so if boh of your devices support that band give it a try! Your wifi will also reach some more distance

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.