Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

vim escape & arrow keys are inserting strange character (the letter q in my case) but works perfectly if launched in a tmux session or with

Someone having the same problem?

share|improve this question

1 Answer 1

up vote 4 down vote accepted

Setting the Report Terminal Type to ansi or linux in my profile solved my problem.

When the terminal type of your sessions is set to one of those "xterm" types, iTerm handles the arrow keys, the home key, and the end key in a special way.

share|improve this answer
this worked for me after i restarted tmux/iterm2 –  Brendon-Van-Heyzen Mar 11 at 17:40

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.