Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm using the Messages Beta on Lion to receive iMessages on my MacBook Pro. I also have my iPhone set up with my iMessage account.

When I receive a message, it's delivered on both devices. If I read the message on my computer, it disappears from the lock screen of my iPhone, so it doesn't fill up during a conversation.

But, this doesn't prevent my iPhone from vibrating every time I receive a message — and if I'm having an extended rapid-fire iMessage conversation with someone using my computer, this can get annoying. Is there any way to prevent this from happening?

share|improve this question
add comment

2 Answers 2

I'm afraid that's not possible in the current iOS.

But there are a few work-arounds:

  • You can define a specific vibrating tone for that specific contact person which will do almost nothing (unlike the default long and hard vibrating)
  • or you can disable vibrating when you enter Silent Mode and when you start having this rapid-fire conversation, just switch your iPhone to silent mode and no vibrating will happen!
share|improve this answer
    
I figured this would be the answer... thanks for the alternatives, though! –  jtbandes Apr 20 '12 at 21:39
add comment
up vote 0 down vote accepted

Nowadays, this seems to be more of a timing issue, and I think Apple has improved the system overall. Basically, it's no longer an issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.