Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My uncle bought a brand new iPhone 4S last week and it is suffering from an annoying problem, side b (not him) hears himself with echo. The error does not occur while using headset or speakerphone, only when using handset.

Is there a fix for that problem?

iPhone 4S
Version 5.1
share|improve this question
Turning the speakerphone on turns off the regular mic's software process. Turning speakerphone off turns the mic's software process back on. So the solution is the good old "turn it off and back on again," but this time "it" is just the mic/audio program, and the only way you have to turn it off and back on is to turn a different mic/audio program on and back off. – user21920 Apr 21 '12 at 18:57
iOS 7.1.1 on a 4S. I am having the exact same problem with the headset (not with earphones, not with a bluetooth handsfree). To add more to confusion, Skype and Hangouts do not present this problem. Only GSM calls. Any ideas would be helpful. – adamo May 3 '14 at 21:59

6 Answers 6

A lot of user complained about this problem. It's been a 37 page long discussion on the Discussion Forum of Apple.

I suggest he goes to the Apple Store, explains his problem and hope they come with a solution.

Meanwhile, he can try a simple fix which seems to solve the problem. You can try to press the speakerphone button on and off again when the echo happens.

share|improve this answer
I am sorry I haven't mentioned it on the question, the error occurs when NOT using headset or speakerphone. – Eran Apr 20 '12 at 9:34
No, that's not what I meant. See my image. Sorry for the language though. – Michiel Apr 20 '12 at 9:41
Maybe my language is a bit incomprehensible. The topic and the fix you're suggesting are regarding to a problem occurs when using handsfree/headset. My problem is when using the handset, the phone itself. – Eran Apr 20 '12 at 9:49

I had this exact problem with a 4S until today. Here is what I did:

I installed Skype and Google Hangouts on the 4S to check whether this problem occurs with any calling application or just GSM. I made calls with Skype and Hangouts via WiFi and had no problem at all.

So I had a friend with a 4S with no such problems and I borrowed his SIM card for a test. I called his number on my 4S and had no echo problems! I put mine back and the echo returned. To make sure, I repeated this a couple of times. My SIM had echo, his no echo.

So I went to my provider's shop and requested a new SIM. Problem gone.

I hope this helps people who have tried all else with no results. Why the SIM caused this is beyond me.

share|improve this answer

I had similar issue, fixed it by replacing the charging/data connection port.

You can test by simply disconnecting the ribbon and then making a call.

share|improve this answer

I had an echo on my iphone 4s and all I had to do is put some scotch tape (or similar) to the little hole beside the headphone socket, job done, no echo!

share|improve this answer
You blocked the secondary mic. The problem might be noise canceling, which can be deactivated by settings. – Jaime Santa Cruz Jul 23 at 12:28

Echo on cellular phones is typically one of two things:

  • A multi path issue where the signal from the cell tower to the phone is bouncing off several surfaces and the phone can't tell which stream is the best so you hear both. Installing software updates (update your iOS) or moving the phone to a different location will solve this cause.

  • If the person you are calling is on speaker phone, you will often hear an echo when you speak - so mute your phone and see if the echo goes away. If so, ask the person you're calling to lower their speaker volume or take their device off speaker phone mode.

  • Sometimes the echo is just bad cellular service or firmware on the carrier side. You would need to contact your cellular service provider to fix that sort of issue.

  • In rare cases, you could have a hardware problem. If the hardware is broken, you could have an internal crack where the sound comes from the receiver and gets picked up by the microphone. You would always have an echo no matter who you called and before / after updating the software. In that case, have your phone diagnosed by a technician or Apple support.

share|improve this answer

My problem is solved. I had the same problem described here but it was solved by removing just one recording app I had installed and did not know it is causing this echo problme for a few weeks. To exclude all the problems regarding your downloaded apps you should back up your phone and without restoring reset your iphone to a new iphone. Again do not do a restore. Then try calling someone. You problem might have been resolved.

share|improve this answer

protected by bmike Jul 23 at 12:36

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.