Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

In my locale digits are represented like this: 100,90 (instead of 100.90 as in the USA), but, even using a PC keyboard, OS X 10.7 is replacing the . in the numpad with a , via software

This is REALLY annoying, for example:

  • I type IP address: 192,168,1,1

  • I type terminal commands: ,/myscript.sh and so on

How I could swap the , for a . but only on the numpad?

share|improve this question
1  
You really need to let us know what you are actually using for us to help. Any additional hardware/OS level information would be most usful. –  stuffe Apr 20 '12 at 10:08

1 Answer 1

up vote 4 down vote accepted

This thread on superuser discusses a similar problem. The accepted answer points to this key mapping program which you may find meets your needs.

The other, more robust but slightly more complex solution, would be to create your own custom keyboard layout using Ukelele. You can then install your custom layout in your ~/Library/Keyboard Layouts folder, and activate it using the System Preferences -> International pane. (the best way to use Ukelele is to duplicate your existing Turkish keyboard layout file and modify just the single key in question).

As a fast solution, and if you don't mind changing other keys on the keyboard, you could use the International pane to switch to a US keyboard layout.

share|improve this answer
    
Love it! Found my exact case in the keyremap4macbook! It means I am not the only one with this weird mapping problem - Apple should listen to users... –  Magnetic_dud Apr 20 '12 at 13:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.