Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I did my first website today using iWeb and I placed it inside the sites folder. From what I understand, this should enable me to show other people my site with this address:

http://my.ip.here/~mynamehere/

But it doesn't work. After some digging, I found out that I needed to go to the System Preferences to Sharing, and turn it on, which I did. I then even went on the internet to get my real IP address because apparently the one the computer gives me is only for people on the same network.

But it still doesn't work. Any ideas on how to make this happen?

Thanks.

share|improve this question
    
What version of MacOS X are you running? Sadly, it makes a difference to the answer to this question. –  Daniel Lawson Apr 18 '12 at 15:25
    
Also, when it "doesn't work", what is the outcome? –  Daniel Lawson Apr 18 '12 at 15:26

2 Answers 2

up vote 5 down vote accepted

You need to make changes to the router that makes your internet connection.

Basically, there are 3 steps you need to complete:

  1. Create your website - you have done this
  2. Enable Sharing on the machine hosting it

    • At this point you have done all you can on your Mac
  3. Get your external IP address, and configure your router to pass through port 80 (or whatever other port number you may use if you are not using the default) requests that come in from the internet to be passed directly to your machine.

    • This can be achieved in a myriad of ways, depending on your choice, your skill level, and how security conscious you are. You can manually "port forward" a single port (80) to a single machine (your Mac), or you can forward everything to a single machine (this is known as putting your machine into the DMZ or De-Militarised Zone) which reduces complexity if you are doing multiple ports at the expense of security (all internet requests will be passed though to your machine, rather than just dropped if they are not specific replies to requests that originated from your machines)
share|improve this answer

You probably need to configure port forwarding on your router (assuming your setup includes a router) so that external connections on port 80 (HTTP) will be able to reach your computer. The way to do this depends highly on your router's manufacturer; you can probably find instructions on their website.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.