Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have my iTunes library on my external hdd and added a track to an playlist.

Everything goes and works fine in iTunes, I can play the whole song from begin to end (also in other applications on MAC/Windows), but it get's stuck and prompts me the error that the file is not readable when I want to sync the song with my iPhone.

I tried to copy & paste the file from the hdd to my laptop's hdd and this works fine. Why can't iTunes copy the file to my iPhone?

share|improve this question
    
What format is the song? –  Gerry Apr 18 '12 at 11:46
    
The track is in mp3 format. –  Sven Apr 18 '12 at 12:00
    
Does anything interesting show up in Console.app? Do you have write permissions on the directory the file is on (not sure why you'd need it, but something to try)? Does this only happen with a single song, while others are fine? Could this be a case-sensitivity issue of the file name? –  Thilo Apr 19 '12 at 1:39
    
@Thilo Console.app? What do you mean? Yes I have write permissions. The drive is formatted as NTFS and I have NTFS-3G installed. Only with this song, it's also the last song I added. The song name is: 'Sahara in the Sun - Coachella Premix 2012.mp3'.. –  Sven Apr 19 '12 at 6:51
    
Added a new mp3 to the playlist and that one is copied to my iPhone without any problems. I deleted and downloaded the song that gives the error and tried it again but gives the same error. –  Sven Apr 19 '12 at 17:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.