Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I held off upgrading my Mac Pro from Snow Leopard to Lion until I had replaced all the important apps that would no longer run.

So far it's OK, but one thing has me baffled is that my Smart Searches in the Finder sidebar all display a ".savedSearch" extension.

I've gone to Finder prefs and unchecked "Show all filename extensions" and I've done a Get Info… on the search themselves and made sure "Hide extension" is clicked.

Neither made a difference.

This doesn't happen on my MacBook, just the Mac Pro.

Any idea how to stop it?

share|improve this question

2 Answers 2

You need to disable "Show all Extensions" in Finder preferences like you have already done. However, current saved searches will still show the extension. Instead of recreating all of your saved searches all over again, just rename them and the saved search will be updated with a hidden extension. Then you can go back and rename it again to its previous name.

share|improve this answer
    
You could also just reopen Finder with osascript -e 'quit app "Finder"' && open -a Finder or by logging out and back in. –  Lri May 30 '12 at 13:50

You will have to recreate your searches since the option to hide the extension is not present if "Show all extensions" is enabled.

Disable "Show all extensions" in Finder preferences (which you have done) Create a new Search in Finder Check the box "Hide Extension" in the resulting dialog

enter image description here

See the original author's explanation here for more information

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.