Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I am on my office network, trying to access our Intranet via iOS Safari. Our Intranet URL is http://Intranet/ (no domain or prefix). Safari never opens this. Is there a way to get to this address on an iPad?

share|improve this question
    
If I browse to intranet, i get a "Safari cannot open the page because the server cannot be found. I am on the same network as this server. –  m1kc Apr 17 '12 at 18:59
    
does this work from a laptop via WiFi? Can you connect via the server's IP? –  Jason Apr 17 '12 at 19:34
    
Are you using wi-fi or 3G/4G? –  lupincho Apr 17 '12 at 20:30
    
@Jason, this works from a laptop via the same wireless network. I can get to the IP. –  m1kc Apr 17 '12 at 20:36
1  
my best guess is that for some reason the device is unable to resolve the DNS for your server. If you can hit the IP it would confirm that theory. However, if that's the case I'm not sure of how to fix it. You might try "forgetting" the network on the device, and then reconnecting. –  Jason Apr 17 '12 at 21:22

4 Answers 4

I went into Settings > General > Search Domains and entered our domain name and now I can go to http://hostname/

If this is the solution, I guess I need to figure out how to set this setting in DHCP.

share|improve this answer

add your domain in the wifi or network in settings. if you click on the wifi that you are connected, you will be able to see the DHCP setting. Under Search Domains, add your internal fully qualified domain name.

share|improve this answer

Try going to http://intranet./ (with a dot at the end of the hostname to make it absolute).

share|improve this answer
    
Same thing... looks like I can't get to any host by hostname only. I need the FQDN... –  m1kc Apr 18 '12 at 13:22

The answer that 'supa' gave was right. I checked my dhcp-server settings and added scope option 15 to push the domainname to clients. If the device was connected in the past you have to clear the 'Searchdomains'-setting. Then back to wifi-settings, when recconnected the setting should be ok. If not, completely erase the wificonnection and reconnect.

If the device was never connected before it works instantly.

share|improve this answer
    
Please can you mark supa's answer as correct and consider adding this as a comment to that same answer. –  Graham Miln Jun 18 at 11:30
    
Please don't add "thank you" as an answer. Once you have sufficient reputation, you will be able to vote up questions and answers that you found helpful. –  Mark Jun 18 at 11:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.