Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have installed iTerm2 and was hoping I'd have something like guake (Yes I just switched from Ubuntu). I mapped the hotkey to a button of my choice and it works fine, but I miss the slide-down-from-top animation like I had in Ubuntu.

share|improve this question
I'm a refugee from Total Terminal coming here for OSX El Captain. – Lakshman Prasad Oct 14 at 10:24
i think iterm2 works, i just had a friend upgrade/downgrade to el capitan and its working fine for him i think. – Aadi Droid Oct 14 at 20:12

3 Answers 3

up vote 69 down vote accepted

You can use iTerm2's system-wide hotkey with the Hotkey Window profile to do this.

In iTerm2 preferences, click on the "Keys" tab. In the bottom left, under "Hotkey", check "Show/hide iTerm2 with a system-wide hotkey" and assign the hotkey you'd like to use.

Check the "Hotkey toggles a dedicated window with profile:" option and choose "Hotkey Window" in the popup menu below (should be selected by default).

With default settings, the Hotkey Profile window will stretch across the top of the screen, and the hotkey will drop the window down from the top, complete with animation.

iTerm2 Quake/visor preferences

You can customize the settings for the "Hotkey Window" profile under the "Profiles" tab.

share|improve this answer
this worked great!! but it keeps popping up the default terminal window, so i close that and then i can use the slide down with the hotkey. any way to stop the default terminal window from popping up? – jere Dec 30 '12 at 0:18
Is there a way to disable the animation? – Lane Aug 25 '13 at 5:30
@Lane Yes - defaults write com.googlecode.iterm2 HotkeyTermAnimationDuration -float 0.00001 – mdrozdziel Oct 29 '13 at 19:43
Thanks @joelseph. Is there any way to have iTerms2 to only show the visor/Quake window on startup instead of the 'normal' iTerm2 window? – snowbound Aug 14 '14 at 4:25
For disabling animation, 0 works just as well. – Behrang Feb 2 at 7:59

If you're not married to iTerm2, you could try TotalTerminal. The slide down window is always a keystroke away.

EDIT - I've loved Total Terminal for a long time. However, in late 2015 I moved to iTerm2. It does all the things I loved TT for, but without any of the issues I ran into.

share|improve this answer
This comment is old as crap so I assume this wasn't the case way back when, but iTerm2 supports a slide down Quake-style console now. – Joel Mellon Aug 21 at 23:21
TotalTerminal does not work with ElCapitan without tweaking the system's security settings. – Guy Oct 4 at 12:11

Turn on multiple desktops, have 2, one on top one on bottom. Assign a hotkey to switch to the TOP desktop. Open iTerm2 and put it in the top desktop and open all other apps on the bottom desktop. Either make the terminal maximized or full screen (lion) and it should give you something similar to what your're looking for.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.