Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

A friend of mine just bought an iPhone. She imported all her SIM contacts using the regular method: Settings > Contacts > Import from SIM All went well.

But when she opens the Messages app, the list is filled with numbers with a country code prefix, so instead of the normal overview of conversations (Tom Dice, David Swimmer, Kim Bauer, etc.), she gets a list with all the numbers of her contacts as name (+324123456, +328945782, etc.).

So, has she imported her contacts the wrong way? Or Iis there some corrupt data in her phone? Or what?

I know it's a pretty vague question without a screenshot, but if you need any more information, please let me know.

share|improve this question
    
Do you observe this in others applications like in Contacts ? –  Ermiar Apr 15 '12 at 14:25
    
The contacts in the Contacts app, show just fine, all with names... –  Michiel Apr 15 '12 at 14:44
    
How was the contacts imported? Is the number imported as the first name or last name of a contact? (Name as in "Nivas +32487259971") –  Nivas Apr 18 '12 at 3:47
    
Check if the phone numbers in contacts appear with country code; most likely not. If so, this means that the SIM card doesn't define the country code, so that the iPhone can't match the phone number with and without country code. What she can do is to manually add the country code to the contacts phone numbers (either in the iPhone or Address Book for Mac or Outlook for Windows). Generally it is always a good idea to enter phone numbers with country code, makes everything work when roaming abroad. –  lupincho Apr 18 '12 at 4:42
    
I agree it's a good practice to always add a country code, but I don't think adding the country code one by one is an option since she has like a zillion numbers... –  Michiel Apr 23 '12 at 6:40
add comment

4 Answers

up vote 1 down vote accepted
+50

It might be how the previous phone she had save the data on the sim card and the iPhone couldn't import it properly and misplaces the data in the import processes.

I suggest you try once again with the same phone with different sim card [or even the same sim card and see]

This will make sure that the phone doesn't have a problem.

Because to me the importing data from sim card most likely a software issues which easy to solve.

share|improve this answer
1  
Her previous phone was a Nokia and afterwards a Blacberry. I'll suggest she tries with an other phone/sim. When you say "easy to solve", doe you have any suggestions besides from the one you already gave? –  Michiel Apr 23 '12 at 6:41
1  
It was indeed an issue with the SIM. Swapping SIMs and GSM's told me so. Thanks for your help! –  Michiel Apr 24 '12 at 16:17
    
I'm glad you have resolve your problem :) –  Ali Apr 24 '12 at 16:26
add comment

Where you said "language code" I guess you meant "country code". Is the country code the code for the country the phone's number is in or is it a different country?

Under Settings -> Phone, does her own phone number have a country code? Is it the same or different that the country code being imported? Does she have "International Assist" turned on or off?

In any case, try picking one of the messages, scrolling to the top, clicking "Add Contact", "Add to existing contact", and add the number to the contact and see what happens. It should restore the names to the Messsage list and you might end up with two numbers for the contact, one with the country code and one without. Then the question is will both work?

share|improve this answer
    
The country code is the prefix off the number where it's registered. What do you mean by "international assist"? –  Michiel Apr 23 '12 at 6:43
    
OK, so under Settings -> Phone, does her own phone number start with + and the country code? International Assist is available on some iPhones to turn on or off dialing country codes automatically. I'm in the US, country code 1, and generally incoming texts from people not in my contact list show up starting with +1, but in my contact list they generally do not have +1 at the beginning. So there's some logic taking care of the country codes. Try poking around with different combinations. Did you try "Add Contact"? –  Old Pro Apr 23 '12 at 6:56
    
Jep, she did. But doing that for each conversation is not a solution since we are talking about a few dozen conversations. –  Michiel Apr 24 '12 at 7:17
    
@Michiel, it wasn't a proposed solution, it was a proposed troubleshooting step. You still haven't answered about "international assist" and when you tried "Add Contact" did you end up with two different numbers in the contact list. If there were two different numbers, what were the differences and how did they appear in the contacts list? –  Old Pro Apr 24 '12 at 8:04
    
I'm sorry. If she "adds contact", she will have a mobile number (0477....) and a iPhone number (+32477....). But it's the same number, just with the country code as prefix. And about the international assist, it's a great tip, but our carrier doesn't support this feature. –  Michiel Apr 24 '12 at 8:20
add comment

This happens when there is a mismatch between the number associated with the conversation in Messages and the number associated with the person in Contacts.

E.g. I can simulate your problem by removing 1 number from the end of the phone number of one of my contacts. Instead of displaying the name in Messages as before it will then display the phone number instead.

Likely this problem exists because the previous phone automatically prepended "+32" to all SMS data instead of using the number as stored on the SIM card. Several solutions are possible :

  • Go through all of the contacts and add the country code (+32, fellow Belgian I see) to their phone number either manually on the phone or desktop or go to the top of the conversation in Messages and tap "Put in list", then "Put in existing contact" to add the full number to the right contact.
  • Delete all conversations, starting over clean the iPhone will associate conversations with the correct number. (I have both numbers with +32 and without in my contacts and SMS are correctly displayed for both.)
  • If you are willing to jailbreak you could probably change the numbers directly in the SMS database.

I've found a thread with an Applescript to add the country code automatically to all contacts here, but have not tested it so use at your own risk (and backup, backup, backup if you do.)

property myAreaCode : "+32 "
tell application "Address Book"
 repeat with aPerson in people
 set thePhones to phones of aPerson
 if thePhones is not {} then
 set errorList to {}
 repeat with aPhoneNumber in thePhones
 set theNumber to value of aPhoneNumber
 if theNumber begins with "0" then

 try
 set value of aPhoneNumber to myAreaCode & (characters 2 thru (number of characters of theNumber) of theNumber)
 on error
 copy name of aPerson to end of errorList
 end try
 end if
 end repeat
 if errorList is not {} then
 display dialog errorList
 end if
 end if
 end repeat
 save
end tell 
share|improve this answer
    
Thanks for the thorough information. But I guess the Applescript is pretty advanced, so I'm not sure if the solutions is in the script since she's quite a noob :) –  Michiel Apr 23 '12 at 6:44
1  
What are geek friends for if not for helping out noobs ? :-) –  Tyr Apr 24 '12 at 14:27
add comment

I had the same issue. My iPhone was fine, but my iPad all of a sudden showed country codes in messages instead of names. Very frustrating. I noticed that my contacts in my iPhone had the (xxx)xxx-xxxx syntax versus my iPad displayed xxxxxxxxxx in my contacts. I do sync my contacts in the cloud.

Solution was to turn off contacts on my iPad (via settings in iCloud on iPad), then it asks for option to keep or delete contacts. I deleted them. I waited to validate that my contacts were removed from my iPad. I turned the contacts on via iCloud again in settings menu on my iPad. Once the contacts came back, the (xxx)xxx-xxxx syntax was back on my iPad. Really weird, not sure why it got "corrupted" all of a sudden.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.