Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm routing dns requests through dnsmasq so that domains I'm using for local development point to This works great when I'm connected to the Internet via Wi-Fi or ethernet, but I start to have problems when I'm not connected to the Internet at all.

In dnsmasq.conf, I have this setting:


Turning off all network connections, I run:

$ dscacheutil -q host -a name test.gentoo
name: test.gentoo

$ ping test.gentoo
PING test.gentoo ( 56 data bytes
64 bytes from icmp_seq=0 ttl=64 time=0.043 ms
64 bytes from icmp_seq=1 ttl=64 time=0.107 ms
64 bytes from icmp_seq=2 ttl=64 time=0.177 ms
--- test.gentoo ping statistics ---
3 packets transmitted, 3 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 0.043/0.109/0.177/0.055 ms

So that seems to be working fine. But if I try to open http://test.gentoo/ in Chrome, I get the message:

Unable to connect to the Internet Google Chrome can't display the webpage because your computer isn't connected to the Internet.

You can try to diagnose the problem by taking the following steps:

Go to Applications > System Preferences > Network > Assist me to test your connection. Error 106 (net::ERR_INTERNET_DISCONNECTED): The Internet connection has been lost.

Chrome sees that I don't have a network connection, and it doesn't even try to make the request.

Any idea how I can work around this? Can I create a dummy network interface to convince Chrome I'm connected to the Internet? Can I make it send the requests even though I'm not connected? Any other ideas?

I tried the solution at but it did not work, as I'm on OS X 10.7.3, so resolver is ignored when not connected to a network.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

The solution on is working for me (OS X 10.9.4). Just make sure to do this step:

Create a file /etc/resolver/whatever:

domain .
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.