Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I close the lid of my Macbook Pro (Lion), it goes to sleep, which is good: it powers down without closing my applications.

But if I just leave the computer unattended for a while without closing the lid, it attempts to shut down instead. It usually fails at this, because there's often a program such as Photoshop (which doesn't use Lion's autosave feature) blocking shutdown with a "Save as" dialog. But it does always succeed, annoyingly, in closing my browser etc. It does this even when the computer is plugged in and fully charged.

When I leave my computer unattended for 15 minutes, I want it to behave exactly as if I had closed the lid: it should go to sleep, not shut down.

How can I do this?

share|improve this question
    
Does your laptop typically try to shutdown at a certain time of the day? If so, it could be that you have the schedule in the energy saver preference pane set to auto-shutdown your computer on a specific time interval. Check System Preferences > Energy Saver > Schedule to see if that is the problem. –  Bryan Luby Apr 11 '12 at 17:21
    
No, I've checked there; there's definitely no scheduled shutdown. Thanks anyway. –  callum Apr 11 '12 at 17:36
    
An app that doesn´t solve your problem but is somewhat related and is very useful is, Caffeine. Very nifty widget, but wont solve your bug... lightheadsw.com/caffeine –  Fredrik Nordström Apr 11 '12 at 19:03
    
@callum Have you taken a look in the Console for any potentially relevant messages either before or after the computer shuts down? If not, click All Messages in the left-hand pane then scroll down to the approximate time period and see whats there. Alternatively, filter the log for "shutdown" or something similar. –  binarybob Apr 11 '12 at 19:43
    
I have the same problem! –  jlarson Aug 28 '12 at 20:30
add comment

4 Answers

It could be the SMC, or a bug in the firmware. Try these two steps:

  1. Reset the SMC, see: http://support.apple.com/kb/ht3964

  2. You may need a firmware update, see: http://support.apple.com/kb/DL1474?viewlocale=en_US&locale=en_US

share|improve this answer
add comment

I know this might not be very helpful... but my guess is that you have an app or widget that has scheduled a shutdown... either that or the energy preferences but you checked that already...

share|improve this answer
add comment
up vote 0 down vote accepted

Thanks for everyone's advice on this. When I asked the question I thought this auto-shutdown thing was some feature I must have accidentally enabled somewhere... But after a lot of searching, update-installing, settings-tweaking, etc, I concluded it was just some rare bug in my system.

In the end, I just re-installed OS X. That fixed it :)

share|improve this answer
    
This did the trick, thanks callum ! I upgraded to Maverick in 2014 and suddenly my mac was constantly logging off and shutting down all apps after 15min. I had that security setting enabled after the upgrade. Thanks for the tip ! –  Sophia Feb 24 at 21:12
add comment

Try going to System Preferences and choosing Security & Privacy. When that application window opens, choose "General" tab and then look to the lower right corner and click on "Advanced". Uncheck "Log out after _ _ minutes of inactivity.

Not sure but this might be the cause.

Good luck

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.