Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I will often use Spaces on Mac OS X 10.5 to switch to another space when a program is busy / unresponsive. Very often, without warning or apparent reason, Spaces will switch back to the first space without my requesting it to do so. Why does it do this and how can i stop it? How can I make spaces only switch in response to my requests?

share|improve this question
    
@mankoff: It does, or worse, it will do it when i am typing something in one app, it will switch me away from that app to a space with another app. It often happens when an app is unresponsive. Like earlier today when I asked this, iTunes couldn't find some songs and was just giving the spinning beachball. I switched spaces to write some code, and every ~5 seconds it would switch back to iTunes, which was still unresponsive. –  Josh Dec 10 '10 at 22:05
    
I don't doubt it. This happens to me a lot. –  Ken Dec 12 '10 at 17:57

1 Answer 1

up vote 8 down vote accepted

Stop Spaces from switching spaces due to an app coming to the foreground:

defaults write com.apple.Dock workspaces-auto-swoosh -bool NO && killall Dock

Or via the GUI: System Prefs > Spaces and then uncheck the checkbox at the bottom: "When switching to an application, switch to a space with open windows for the application"

Stop (slow down) Spaces from switching spaces if your mouse presses against the edge of the desktop:

defaults write com.apple.dock workspaces-edge-delay -float 60 && killall Dock
share|improve this answer
    
nice one mankoff! –  fady Dec 10 '10 at 20:46
    
That first one sounds perfect, but I just did it and now, when I click an app in the dock, the system no longer switches to that space. If it also solves the issue I was having, I can live with it however :-) –  Josh Dec 10 '10 at 22:03
    
@Josh I find the first one necessary. What if I want two terminals open on different spaces? Or a new browser in the current space? Not easily possible if the spaces keep switching elsewhere... –  user588 Dec 10 '10 at 22:45
    
I found that System Preferences -> Spaces -> Turn Off, was the solution to 100% of the problems spaces was giving me. I have dual screens, so “context” switching is not for me, I hide things I don’t use. But then again, I have 12GB of RAM so I understand that in small screens or more constricted environments the simplicity of having different contexts and being able to switch to them might be desirable. I’d use spaces if I could make the switch instant, as fast as a HIDE/UNHIDE works. I don’t like the swooosh thing. –  Martín Marconcini Dec 11 '10 at 14:53
2  
I tried your solution and it stops switching if an app is already open, but how can I prevent the switch if an app opens in an other space. E.g. I’m on space 1 and iTunes is set to show always on space 2, if I start iTunes while working on space 1 Leopard switches to space two automatically. Is it possible to open iTunes on the second space in the “background”? –  Tobi Mar 23 '12 at 13:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.