Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm on Lion and I like to use the multimedia Next Track, Play/Pause, and Previous Track keys to control iTunes.

Every once in a while, these keys basically stop working. Sometimes they just don't work and sometimes the action is delayed by minutes. I'll hit the key out of habit and then nothing will happen, so I'll go into iTunes and pause. Then maybe 5 minutes later, it will unpause (presumably because the key event finally made it to iTunes.)

Any idea what in the world is going on? The only thing that seems to fix it is a reboot (though a log out and log in might do it as well. Not in a position to try that at the moment.)

Argh! It just happened again. Super annoying.

share|improve this question

1 Answer 1

I finally just figured it out! It turns out that I had a Quicktime process that was stopped (I had done an open on an avi file on the command line.) A kill -CONT on the pid allowed it to continue so I could close it and now I have my keys back!

share|improve this answer
    
any chance of explaining this in simpler terms? I have the same problem of delay with the transport keys but don't understand how you remedied it. thanks. –  user34850 Nov 16 '12 at 15:13
    
Open up your activity monitor and see if quicktime is listed. If it is, stop the process. –  Nathan Binkert Nov 16 '12 at 18:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.