Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

So I bought a new iPad, 64GB + 4G. And since then it seems like every time I pick it up and go to use a network feature (Hero Academy, Tweetbot, Safari etc.) I get this message "Could not activate cellular data network".

If I reset it then everything will work OK until after I put it away for a while. There's no definite time period for the network failing but it always seems to happen after I have been home or at work (inside a WiFi coverage area) and then I go to use 3G again. The fact that it does work fine after a reset says to me that this is not a signal strength issue, this happens repeatedly at the train station and will always work right after reset. Before reset the network indicator shows full bars and 3G indicator.

Has anyone else experienced this and improved this by changing anything in Settings, by talking to their carrier or anything else? I am thinking this has to be an iOS bug. I should not have to do a white apple reset to use network services!

If it matters I am using a prepaid Optus 3G sim in Melbourne, Australia. My only APN setting is the APN field which is "connectme", correct according to the Optus guide I got with my sim. (new iPad cannot use the 4G networks available in Australia: Australian Competition & Consumer Commission)

share|improve this question
    
I have exactly the same problem. My iPad is wifi + 4G 16GB. Everything that was written on top could have been written by me. I use the network TMN in Portugal, and the only difference is that I'm in a contract, and not in a prepaid. –  user21236 Apr 5 '12 at 7:15
1  
How do you reset the iPad? –  Michiel Apr 5 '12 at 7:22
1  
Hold top and home buttons until white apple appears. Don't know who is down voting you, not me! –  Adam Eberbach Apr 5 '12 at 7:52
    
In that case, see my edit :) –  Michiel Apr 5 '12 at 8:15
    
I also had this on T-Mobile UK (3G and HSDPA only, not LTE, network shared with Orange UK), so I don't think it's an operator specific issue. The fix (so far) was mark's suggestion below: apple.stackexchange.com/a/48931/12164 –  RichVel Jun 1 '12 at 10:59
show 1 more comment

2 Answers

I have had exactly the same issues with my New Ipad 16Gb 4G. The only way I have found that really gets round it, is to manually select the Network provider, insteady of leaving it set to the 'Automatic' setting. Come on Optus sort this out !!

share|improve this answer
    
This worked for me - having similar problem with the new iPad (iPad 3) on T-Mobile UK. I also tried rebooting, checking APN settings, but this is the only thing that worked. Recommend people try this as it's not at all disruptive compared to rebooting, resetting network settings, etc. –  RichVel Jun 1 '12 at 10:57
    
You are great! I spent hours doing complicated things when it was this simple!!!!!!!! –  Ryan Sep 23 '13 at 15:04
add comment

According to the website of Optus, all should be working after a sync with iTunes (this is about an iPhone, but I'm sure it applicable to an iPad as well):

iPhone
iPhone specific APNs and technical settings are automatically provisioned when you first connect your iPhone (with an Optus SIM card inserted) to iTunes and activate your service. Performing a restore will also resend these settings to your iPhone.

UPDATE:
Try to reset your network settings by going to Settings > General > Reset > Reset Network Settings

enter image description here

share|improve this answer
    
If you cast a negative vote, please leave a comment so I can improve my answer where you think it's needed... –  Michiel Apr 5 '12 at 7:46
    
I would have thought I had any required setting but could try it again I suppose. I did sync to restore my old iPad's backup data to the new one. –  Adam Eberbach Apr 5 '12 at 7:53
    
Thanks - tried it but no luck. Still complains that "couldn't activate the cellular network". –  Grant Sayer Apr 6 '12 at 5:39
add comment

protected by Community May 20 '13 at 13:41

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.