Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've been trying to work out whats going wrong on my iTune library

When I was syncing my iPhone tonight I noticed that under iPhone>Music there were approx. 150 songs that were grey with a "sync" symbol against them as well as a check mark.

I was using iTunes Match with no problem up to now.

I switched off Match and synced. nada.

I deleted all the music on the iPhone using General>Usage>Music. They are still there.

the iPhone reports having no songs on it under About. I've tried dragging the songs to the iPhone with match switched off and only some of them copy.

I switched on Match again. still there are 150 songs that are grey.

It looks like iTunes thinks that the songs should be on the iPhone but aren't.

Any suggestions?

share|improve this question
    
What shows in the sync-related tick boxes on the main iPhone page in iTunes? Also, how about the Music page? –  timothymh Apr 4 '12 at 10:52
    
Music plays fine under iTunes for the selected tracks. I generally use –  Dan Kelly Apr 4 '12 at 17:53
    
I think your comment didn't work out the way you wanted. Also, to be clear: I meant the Music tab visible in the main window when the iPhone is selected in the sidebar. –  timothymh Apr 4 '12 at 20:32
    
Oops. If I turn off Match and switch to Manually manage then iTunes tries to delete the tracks but the reappear next time. Nothing is selected on the Music tab of the iPhone settings. –  Dan Kelly Apr 5 '12 at 11:48

2 Answers 2

See if this works for you... but this will remove ALL OF YOUR MUSIC FROM YOUR PHONE. So, I hope you have it somewhere else before doing these steps.

  • Uncheck "Sync Music" in iTunes on the Music tab for your iPhone.
  • Check "Manually manage music and videos" in iTunes on the Summary tab for your iPhone.
  • Go to the Music on the left tree under your iPhone in iTunes.
  • Select all of the music (CMD-A) and delete all of the songs.
  • Go back to the Summary Tab and click Sync.
  • At this point, your iPhone will have no music on it and will report that correctly.

This worked for my iPhone that was stuck in some weird limbo with Match. I was able to turn back on Sync Music and do the albums I wanted. Now my iPhone's Usage count matches iTunes.

share|improve this answer
    
This didn't actually help for me. –  Dan Kelly Jun 29 '12 at 8:07
    
Bummer. :( Pretty frustrating situation. Are the songs showing up grayed out on the Music page? –  Eliot Jun 29 '12 at 14:35
up vote 0 down vote accepted

Unfortunately despite trying the suggestions above my only solution was to restore from a backup.

share|improve this answer
    
If this worked for you, please accept your answer by checking the green checkmark next to your answer. –  daviesgeek Jul 18 '12 at 6:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.