Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Xcode 4.3.1 two days ago. I need to access the iOS 4.3 device simulator, but it is not available in the new Xcode. So I went to Xcode > Preferences > Download (tab) and downloaded the Xcode 4.3.1 developer library and the iOS 5.1 library, hoping I could add the 4.3 simulator.

But, this hasn't worked. So far I haven't got the 4.3 simulator installed on my Xcode. What is the solution for this?

share|improve this question
Well in mine, when i click on downloads, it doesn;t show iOS 4.3 Stimulator – illep Apr 2 '12 at 17:00
up vote 3 down vote accepted

The option to download iOS 4.3 simulator is available from within Xcode. You can find it under Preferences > Downloads. Just click on "Install" and you might have to enter your Apple ID credentials.

enter image description here

If you don't see this option, you could try removing your older versions of Xcode and installing the latest one from the Appstore. My version is 4.3.2.

share|improve this answer
I have xcode 4.3.1. Do you want me to uninstall it ? – illep Apr 3 '12 at 16:14

The iOS Simulator app can be found here if it’s installed correctly:


Or here:


Try a Spotlight search for “Simulator” to make sure the installation actually failed, before you try anything else.

share|improve this answer
How can i navigate to the above paths. I tried spotlight but i was unable to find Simulator there – illep Apr 2 '12 at 17:05
Open and enter open /Developer/Platforms/iPhoneSimulator.platform/Developer/Applications; open /Applications/‌​veloper/Applications. – Mathias Bynens Apr 2 '12 at 18:17

In the iPhone Simulator, select required iOS version (4.3.2) from Hardware > Version menu.

share|improve this answer
In Hardware-->Version there's only 5.1 (98176). I need 4.3 :S – illep Apr 2 '12 at 17:15
Try upgrading Xcode to 4.3.2 and check Preferences->Downloads again – Dmitry Alexeyev Apr 2 '12 at 17:33

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.