Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I use a unibody Mac laptop to read recipes or listen to music while in the kitchen. The wireless disconnects sometimes. How can I prevent this?

share|improve this question
    
Note to everyone posting the same answer here, at no point has the use of a Microwave been confirmed by the OP, it's just speculation. Reading the wording there's nothing to suggest that it couldn't just be at the limit of reception etc. Also, for me cooking involves using an oven or grill, or hobs, using a microwave is merely heating... ;) –  stuffe Oct 9 '13 at 14:40

5 Answers 5

Yep, the Microwave is interfering with the WiFi. If you have an Apple Time Capsule, you can use the 5GHz Network, or Broadcast either 2.4GHZ or 5GHz on another Channel. Please note that Cordless Phones and Other Devices can also interfere with your WiFi. It's also important to note the Hardware on the Network--what Wireless Signal Standard they have (a/b/g/n/ac), and what the Neighbors have that could also be a factor.

share|improve this answer

I got mad today and started to test my microwave. I just placed 2 baking plate on the top of microwave like one covering backside and another covering right side gap because my microwave is placed in the corner of kitchen. So I just covered the gap on the top 2 sides only. I started to heat my coffee for 1 min and I do see this worked and did not disconnect my wireless connection.

I again did the test one more time to make sure it works and worked. So my conclusion is that you need to shield your microwave is the simple solution.

share|improve this answer

This really has nothing to do with unibody or Macs, but is rather due to physics. I'm guessing that you're cooking using a microwave oven or have it running nearby when you're using your laptop.

The 802.11b WLANs operate in the 2.4 GHz band. Unfortunately, microwave signals also fall in the same frequency band, and hence can cause interference with your wireless signal. If the interference is too high (depending on how your home is setup, how close the microwave oven is, etc.), your receiver can drop the connection.

An alternative to this would be to use a routing device that uses 802.11a. This operates at 5 GHz, which is outside the interference band and you won't notice this problem. However, the drawback is that since it's higher it frequency, it attenuates faster. This means that it will not travel as far as the 802.11b and will not penetrate through walls, etc. So if you have a big house, this might not be feasible unless if you want to set up multiple hotspots. From the linked wiki article:

Since the 2.4 GHz band is heavily used to the point of being crowded, using the relatively unused 5 GHz band gives 802.11a a significant advantage. However, this high carrier frequency also brings a disadvantage: the effective overall range of 802.11a is less than that of 802.11b/g.In theory, 802.11a signals are absorbed more readily by walls and other solid objects in their path due to their smaller wavelength and, as a result, cannot penetrate as far as those of 802.11b.


You can also programmatically test this. You can get your wireless details from the command line with

/System/Library/PrivateFrameworks/Apple80211.framework/Versions/Current/Resources/airport -I

The entries corresponding to agrCtlRSSI and agrCtlNoise will give you the strength of the signal and interference respectively. Here's what a quick experiment in my house shows (explanation follows):

enter image description here

In the figure, you can see the change in wireless signal strength and interference as I walk from near the router (at time 0) into the room farthest away. The point to note here is that signal decreases, but noise background remains at the same level.

Then I return to the dining (next to the kitchen) and turn the microwave on for a minute (highlighted time periods). You can see how the interference increases and is higher in the next trial, when I move it to the kitchen (but not near the microwave). Note that these levels are in decibels, which means that a 3dB increase implies a doubling of interference.

The third time, I put it right next to the microwave and my laptop dropped the signal because the interference was just way too high. You can get a glimpse of how high it was, when you see it drop down to normal levels after turning the microwave off. All this while, the signal strength remained the same.

Summary: Your kitchen appliances are interfering with your signal and if you happened to be far enough from the router that your signal levels are also low, you can experience difficulties even without being that close to the appliance.


Obligatory XKCD:

'Cheater!' 'Hey, gaming on wifi? You have only yourself to blame.'

'Cheater!' 'Hey, gaming on wifi? You have only yourself to blame.'

share|improve this answer
3  
+1 for the experiment and well presented results! –  Adam Davis Apr 2 '12 at 18:22
1  
You'll be gutted when the OP says she is using a grill ;) –  stuffe Apr 2 '12 at 18:43
    
1) It appears from Wikipedia that 802.11g is in the same 2.4GHz band; you might mention that. 2) How does 802.11n fit into things? 3) You sorta say, but I can't tell: does the microwave only interfere when it's on, or does it interfere all the time? –  zpletan Apr 2 '12 at 22:09
    
@zpletan 802.11n uses either 2.4GHz or 5GHz bands depending on the hardware and settings. All 802.11n devices are 2.4GHz capable but not necessarily working with 5GHz bands. The microwave interferes when cooking, some power-supplies also interfere and some electric (induction) stoves create interferences as well. –  Coyote Apr 3 '12 at 1:12
    
@RM I wouldn't say the unibody mac has nothing to do with the problem, we'd need more data to evaluate, but your experiment I will try. Danke. –  CHM Apr 6 '12 at 17:22

When you are running the microwave oven, your wireless network may sometimes be disrupted enough to disconnect until the microwave finishes cooking.

If it happens at other times, another electrical appliance may be creating enough interference to cause a disconnect. For instance, if your laptop is too close to an induction cooktop, or to a particularly old high power blender, such as an old vita-mix. Older generation applicances aften do not follow the latest EMC and FCC standards for electromagnetic noise and radiation, and older devices with electrical motors often produce a significant amount of noise due to old brushes.

Narrow down which appliance is the problem by trying them out one at a time and seeing which one causes the disconnection.

If it's the microwave, you can try relocating the laptop or wireless router, but a new microwave will probably have the same issue.

I resolved the issue in my home by installing a wireless router capable of the 802.11a or 802.11n band, which run at 5GHz, which the microwave does not conflict with. Make sure your Mac supports 802.11a or n before trying this.

If it's another appliance, you should be able to resolve the problem by replacing the appliance.

You may also find good results by moving your laptop to another area in the kitchen away from the problem appliance, and letting it run on battery power, since some of these emissions can be carried over the AC wiring. A higher power or more recent router may also resolve the problem, as well as relocating the router closer to the kitchen.

share|improve this answer

Simple Version of the other answers:

You're kitchen appliances' microwaves are jamming the Wi-Fi from your router and preventing it from getting to your mac.

share|improve this answer
3  
This answer doesn't really add anything to the question. If you think the other answers need a "TL;DR" section, edit the answers to have one. –  CajunLuke Apr 2 '12 at 19:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.