Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've set up a brand-new internet connection with a Wireless Router.

The thing is that :

  • It works all the time for my iMac
  • It stops working at times on my MacBook Pro (either when connected via wifi, or using an ethernet cable), so I have to "Turn Wifi Off", then "Turn Wifi On" and reconnect, or simply re-plug in my ethernet cable.

UPDATE


My iMac specs

  • Model : iMac11,2 - Intel Core i3 (3.06GHz)
  • OS : 10.6.8 (Snow Leopard)

My MacBook Pro specs

  • Model : MacBookPro8,1 - Intel Core i5 (2.3GHz) [early 2011]
  • OS : 10.7.3 (Lion)

My Router specs

  • Brand : ZTE
  • Model : ZXV10 W300 v5.2

I'm sure it may have something to do with my connection settings, but I'm not sure what it is...

Any ideas?

share|improve this question
    
Did you change your WiFi password? –  Mehdi Hadjar Apr 15 '12 at 0:50
    
@MehdiHadjar Yep, I had changed it at some point. However, note that my issue exists even with an ethernet cable, huh? –  Dr.Kameleon Apr 15 '12 at 1:02
    
I used to have the same problem and solved by changing WiFi name. –  Mehdi Hadjar Apr 15 '12 at 1:07
    
@MehdiHadjar Really? I'll give it a shot. Give me some time and I'll let you know how it went... –  Dr.Kameleon Apr 15 '12 at 1:08
1  
It would be helpful to have an extract of the system log (available through Console.app) to see if there are any related errors at the time of disconnect. –  Tyr Apr 15 '12 at 11:15

6 Answers 6

up vote 3 down vote accepted
+50

Mac Wireless & Airport Connection Problem Troubleshooting: The Basics * Turn Airport on & off – You can do this via the Airport menu bar or from the Network Preferences. This is the first thing you should try when troubleshooting Mac wireless problems.

  • Reset your router – This is the second thing you should try doing. You can fix a surprising amount of wireless problems just by resetting the airport/router. All you need to do is turn the thing off for a few seconds and turn it back on.

  • Reset your Cable/DSL modem – You’ll usually want to reset this in combination with your wireless router. Reset this first so the DHCP information will be pulled to the wireless router properly.

  • Change Wireless Channels – sometimes your router’s wireless broadcast channel will interfere with a neighbors, be sure you have your router set to a unique channel. Even if it’s a weak signal there can still be interference.

  • Make sure Wireless/Airport card software & firmware is up to date – This is usually done just by going to the Software Update menu, if there are any updates available for your Mac or Airport, install them.

Mac Wireless Troubleshooting: Intermediate * Change wireless security protocol – You shouldn’t be using WEP anyway for security reasons, but sometimes changing from WEP to WPA/WPA2 or WPA to WPA2 can resolve wireless connection difficulties.

  • Make sure router firmware is up to date – Check your router manufacturers website for firmware updates, if there are any available, install them.

  • Delete and recreate connection – Try deleting and recreating/reestablishing the wireless connection, sometimes a setting can be corrupted and this may fix it.

  • Create a new Network Location – Similar to the above suggestion, try creating a new and different wireless network location to see if it resolves the connection problems.

  • Change DHCP auto settings to manual – sometimes there is a problem with the DHCP server, and if you manually set an IP address on the network you can be fine. Remember to set the IP to a high number so it wouldn’t interfere with other DHCP machines. As long as you have the subnet mask, router, and DNS settings configured manually as well, this shouldn’t be a problem.

  • Disable “Wireless G/N/B only” mode – Sometimes a setting is selected that only broadcasts your wireless signal in Wireless B, G, or N mode (depending on the routers abilities). If this is set, try disabling it.

  • Flush the DNS cache – Launch the Terminal and enter the following command onto one full line within the Terminal:

    dscacheutil -flushcache
    

Mac Wireless Connection Problem Troubleshooting: Advanced * Zap the PRAM – Reboot your Mac and hold Command+Option+P+R during restart until you hear another chime, let the Mac boot as usual.

  • Delete Wireless Config files – Delete com.apple.internetconfigpriv.plist and com.apple.internetconfig.plist files from ~/Library/Preferences and reboot

  • Trash your home directories SystemConfiguration – Remove all files within ~/Library/Preferences/SystemConfiguration/ and then reboot your Mac.

  • Reset your Mac’s System Management Controller (SMC) – For MacBook and MacBook Pro’s: Shutdown the MacBook/Pro, remove the battery, disconnect the power, hold the Power Key for 15 seconds. Replace the battery, reconnect power, and zap the PRAM and wait for 2 chimes before letting the keys go. Let boot as usual.

source: osxdaily.com http://osxdaily.com/2009/12/22/mac-wireless-problems-guide-to-troubleshooting-airport-wireless-problems-on-your-mac/

share|improve this answer

Have you tried switching from DHCP to manual setup? Sometimes when i've put my MBP to sleep and wake it up the connection is lost and the only way to get back up is turn the WiFi off (i do this through terminal for speed):

$ sudo ifconfig en1 down
$ sudo ifconfig en1 up

Using manual setup doesn't work in my case since it is the University network of Delft (NL). But at your home network it won't hurt to use a static ip and other static settings.

share|improve this answer
    
you should try "sudo ifconfig en1 down;sudo ifconfig en1 up" to do the 2 steps successively in 1 step –  XAleXOwnZX Apr 21 '12 at 4:13

Official Apple Support doc on wifi networks:

http://support.apple.com/kb/HT4199

One thing I noticed recently on my own network was that I was using a 40MHz band but Apple don't actually support that band, just 20MHz bands. I switched my wifi at home but haven't been using it long enough yet to say if it has made much difference.

Also make sure that your wifi is turned off if you are using the ethernet cable. This will help you determine if it is a problem with just the wifi or with the wifi and the ethernet.

You could also get a utility from the Mac App Store to investigate your wifi network. As the first google result I got(wifi explorer): http://itunes.apple.com/us/app/wifi-explorer/id494803304?mt=12 but I haven't tested it or any similar programs myself so I can't say for sure how helpful they would be.

share|improve this answer

Make sure the name of your WiFi network (the SSID) is unique in your area and that you have WPA2 turned on. Otherwise your laptop could get confused trying to connect to another router with the same name. And of course verify that you have adequate signal strength for communication between the router and the laptop.

Make sure the router's DHCP server is turned on. If you have an option for setting the lease time for DHCP, set it to at least 24 hours.

If you really think it's a configuration error and the above steps don't resolve it, then delete and recreate both your Wi-Fi and Ethernet interfaces in the Network System Preferences and just leave them at the default settings.

share|improve this answer

I had this problem, and my understanding is that the disconnection issues had to do with the plethora of wifi routers in my building. Changing the channel on my router solved the problem.

The process for doing this will depend on your router. Generally you will log in to your router through a browser and change one setting. Check the router manufacturer's instructions.

The first Google result I get for "change router channel" provides some generic directions for figuring out what channel to use:

http://www.howtogeek.com/howto/21132/change-your-wi-fi-router-channel-to-optimize-your-wireless-signal/

To be honest, I was lazy and just picked an alternate channel. 5 through 11 are often good options.

share|improve this answer

Try to use NetSpot. It's an excellent free mac utility that lets you scan your area for wi-fi signals, and create floor plans best suited for delivering strong wireless connections. http://www.netspotapp.com/

share|improve this answer
    
It seems that if the wired connection is failing in addition to Wi-Fi problems we could rule out wireless interference as a cause. –  bmike Nov 14 '12 at 22:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.