Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I recently received an iPhone 3G from a friend. She took out her SIM card, so I don't have a SIM on my iPhone. I heard that you can now text on iMessage using your email instead of a phone number. I went to Settings > Messages, and I put in my email address, but my friend's number is on top. I'm tying to delete it, but I can't. I also have no SIM.

share|improve this question
    
And first of all it is not iPhone 3G that you've received. It must be 3GS and up because you need iOS 5 for iMessages and 3g is capped at iOS 4 –  iskra Apr 17 '12 at 1:15
add comment

1 Answer 1

This is the same set of steps you would use if you had a sim card, it's more about clearing the account that device has registered with the iMessage service.

Try to turn off iMessage completely, totally log out of the system in Settings > Messages. When you re-enable it, ensure you log in with your own Apple ID. At this point, you should be able to message to your registered email address.

If that doesn't work, you may need to back everything up and restore the device. This is somewhat problematic without a SIM card, since you may get stuck at activation if you don't at least have an inactive SIM from the proper carrier.

share|improve this answer
    
Maybe the best summary of all the various links and stories is thenextweb.com/apple/2012/02/02/… - I've experienced this too. Disabling then re-enabling iMessage appears to be the right fix. –  Adam Eberbach Apr 1 '12 at 22:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.